[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ImageMagick configure issues.

From: Ralf Wildenhues
Subject: Re: ImageMagick configure issues.
Date: Thu, 26 Mar 2009 21:10:55 +0100
User-agent: Mutt/1.5.18 (2008-05-17)

Hello Julie,

thanks for the report.

* Julie Bell wrote on Thu, Mar 26, 2009 at 07:45:54PM CET:
> I am have my source in:
> /u/Image/ImageMagic-6.5.0-2
> I am in this directory as super user.
> ./configure CC=cc --without-perl
> I get 
> .configure[1225] : is not an identifier.

Hmm.  I remember seeing this before, but it's been a while.  Can you
post the output of
  ./configure --version

so we know which Autoconf version this comes from?

The most likely reason for such errors are bugs in the shell;
some experience memory corruption and then fail rather unpredictably.
If you have a less buggy shell on this system, for example bash,
you can try running
  CONFIG_SHELL=/usr/bin/bash /usr/bin/bash ./configure CC=cc --without-perl

with the paths to the shell adjusted, and see if it works better
(sorry about the need to duplicate this).

Of course you can also try one of the other Bourne-like shells that this
system has installed.

> I put in echo's to see where in configure it is stopping.
> Line 1224: SHELL'
> Line 1225: ac_subst_files=''
> Line 1226: ac_user_opts='
> It starts at the top, 3 different times, and finally bombs at this point.


> I have tried many different things an can't seem to get this configure
> to work. I tried taking out lines 174-724, and then proceeded to get
> other errors. Like awk, nawk not found etc.

Do you have neither of awk, mawk, or nawk installed?  That would be a
problem, at least with packages that use Autoconf 2.62 or newer: it
uses awk to do the substitutions in the *.in files.

In this case, you might need to install an awk first (for Autoconf's
purposes, any awk will do, I do not know if ImageMagick requires more
specific awk functionality).

> The uname-m = i386
>     uname-r = 3.2
>     uname-s = SCO_SV
>     uname-v = 2
> Kernal= 96/01/23
> Machine= Pentium
> Bus Type = ISA
> cc -V 
> SCO UNIX Development System Release 5.0.0a 16Mar95

Hope that helps.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]