[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems when installing Lilypond on windows

From: Ulrich Vollert
Subject: Re: problems when installing Lilypond on windows
Date: Tue, 4 May 2004 16:53:44 +0200


the tetex package tetex-tiny is installed. Have a look at the list of
cygwin-modules below which are installed on my system. Which modules
should I install additionally?

In the meantime, I tried a reinstall, I installed the older version of
Lilypond 2.0.1 and I even deleted my whole cygwin-installation to
install everything new.

Always the same result: only a short cygwin-window appears when
double-clicking the file test.ly on my Windows Desktop. And when I start
Lilypond inside cygwin with

        lily-wins test.ly

I get the following test.log saying that 'feta20.afm' couldnt be


lilypond (GNU LilyPond) 2.2.0
Starte lilypond-bin...
Now processing `test.ly'
Interpreting music... error: kann `feta20.afm' nicht finden
Schriftarten wurden nicht ordnungsgem"ass installiert. Abbruch

lilypond: error: LilyPond scheiterte an der Eingabedatei test (Rückgabewert 1).
lilypond: warning: LilyPond-Aufruf gescheitert. Versuchen Sie es erneut mit 
--verbose für ein Protokoll.


I am not an expert with cygwin. I tried the command

        kpsewhich feta20.afm

because I found something similar in the Python script and got no
answer (!?).

No result for the following command

        kpsewhich feta20.pfa

But the fonts are in the corresponding directories


What should I do now?



Cygwin Package Information
Package              Version            Status
_update-info-dir     00227-1            OK
ash                  20040127-1         OK
base-files           2.6-1              OK
base-passwd          1.1-1              OK
bash                 2.05b-16           OK
bzip2                1.0.2-5            OK
clear                1.0-1              OK
crypt                1.1-1              OK
cygutils             1.2.5-1            OK
cygwin               1.5.9-1            OK
cygwin-doc           1.3-7              OK
diffutils            2.8.7-1            OK
ed                   0.2-1              OK
editrights           1.01-1             OK
expat                1.95.7-1           OK
fileutils            4.1-2              OK
findutils            4.1.7-4            OK
gawk                 3.1.3-4            OK
gdbm                 1.8.3-7            OK
ghostscript          7.05-2             OK
ghostscript-base     7.05-2             OK
grep                 2.5-1              OK
groff                1.18.1-2           OK
guile                1.6.4-12           OK
guile-doc            1.6.4-12           OK
gzip                 1.3.5-1            OK
less                 381-1              OK
libbz2_1             1.0.2-5            OK
libdb4.1             4.1.25-1           OK
libdb4.2             4.2.52-1           OK
libgdbm              1.8.0-5            OK
libgdbm-devel        1.8.3-7            OK
libgdbm3             1.8.3-3            OK
libgdbm4             1.8.3-7            OK
libgettextpo0        0.12.1-3           OK
libguile12           1.6.4-12           OK
libguile12abi13      1.6.4-2            OK
libiconv2            1.9.1-3            OK
libintl1             0.10.40-1          OK
libintl2             0.12.1-3           OK
libjpeg62            6b-11              OK
libjpeg6b            6b-8               OK
libkpathsea3         2.0.2-13           OK
libkpathsea3abi13    2.0.2-2            OK
libltdl3             1.5-3              OK
libncurses5          5.2-1              OK
libncurses6          5.2-8              OK
libncurses7          5.3-4              OK
libpcre              4.1-1              OK
libpcre0             4.5-1              OK
libpng12             1.2.5-4            OK
libpopt0             1.6.4-4            OK
libreadline4         4.1-2              OK
libreadline5         4.3-5              OK
libtiff3             3.6.0-2            OK
libtiff4             3.6.0-5            OK
lilypond             2.2.0-1            OK
lilypond-doc         2.2.0-1            OK
login                1.9-7              OK
man                  1.5k-3             OK
mktemp               1.5-3              OK
ncurses              5.3-4              OK
openssl              0.9.7d-1           OK
perl                 5.8.2-1            OK
python               2.3.3-2            OK
readline             4.3-5              OK
sed                  4.0.9-2            OK
sh-utils             2.0.15-4           OK
tar                  1.13.25-5          OK
tcltk                20030901-1         OK
termcap              20021106-2         OK
terminfo             5.3_20030726-1     OK
tetex-base           2.0.2-13           OK
tetex-bin            2.0.2-13           OK
tetex-tiny           2.0.2-13           OK
texinfo              4.2-4              OK
textutils            2.0.21-1           OK
vim                  6.2.098-1          OK
which                1.5-2              OK
zlib                 1.2.1-1            OK

On Tue, 4 May 2004 10:35:09 +0200
"Bertalan Fodor" <address@hidden> wrote:

> Cygwin setup has a bug: it doesn't correctly solve package dependencies.
> Please run setup again and ensure that a tetex package is selected
> (theoretically tetex-tiny should be automatically selected and should be
> enough when you install lilypond).
> Bert

reply via email to

[Prev in Thread] Current Thread [Next in Thread]