[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LilyPond doesn't process files under Windows

From: Mats Bengtsson
Subject: Re: LilyPond doesn't process files under Windows
Date: Mon, 19 Mar 2007 11:04:08 +0100
User-agent: Thunderbird (X11/20070221)

Uwe wrote:
I'm using LilyPond 2.10.20. When I want to process a .ly-file nothing happens:
No matter what I try to generate a PDF, only a logfile is created. Here is the
content of the logfile:

# -*-compilation-*-
»D:/Download/catalan.ly« wird verarbeitet

that means in English:
»D:/Download/catalan.ly« is processed

These things can happen if you have a problem in your file, that makes LilyPond
crash. Have you tried some example that you know for sure that it works?
Also, check if it possibly has anything to do with the fact that you have
your .ly file and the program installation on different disks.

There is additionally a problem when the .ly-file is in a path with parentheses
and spaces:

# -*-compilation-*-
aktuelles Verzeichnis kann nicht zu »C:/Program Files
(x86)/LilyPond/usr/share/lilypond/current/ly« geändert werden
»C:/Program Files (x86)/LilyPond/usr/share/lilypond/current/ly/catalan.ly« wird

That's in English:
actual folder cannot be changed to
»C:/Program Files (x86)/LilyPond/usr/share/lilypond/current/ly«
»C:/Program Files (x86)/LilyPond/usr/share/lilypond/current/ly/catalan.ly«
is processed

(I have write permissions to this folder.)
Yes, but it's not a file that should be modified, right? The catalan.ly file is one that you include into your own file. I haven't experienced any problems with 2.10.20 installed
under C:/Program Files/...
but I have never tried to install in a folder with parenthesis in the patt, though.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]