[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: no output when LilyPond is run from the command-line

From: Colin Hall
Subject: Re: no output when LilyPond is run from the command-line
Date: Sat, 16 Feb 2013 10:38:01 +0000
User-agent: mu4e; emacs 23.3.1

Colin Hall writes:

> Eluze writes:
>> Am 15.02.2013 17:40, schrieb Phil Holmes:
>>> "Eluze" <address@hidden> wrote in message 
>>> news:address@hidden
>>>> if in the command-line I enter
>>>> /lilypond/ or /lilypond -h/
>>>> nothing happens (version "2.17.12" windows7)
>>>> only if I use a bat file and redirect the output like
>>>> lilypond -V D:\Data\lytest\test9.ly 1>>test9-1.log 2>>test9-2.log
>>>> I get the log in test9-2.log and the pdf is created.
>>>> is anything known about such behavior?
>>> Is this new in 2.17.12?
>> absolutely - it was always working before.
>> and I also tried
>> "c:\program files (x86)\lilypond2.17.11\usr\bin\lilypond.exe" 
>> D:\Data\lytest\test9.ly
>> "c:\program files (x86)\lilypond2.17.12\usr\bin\lilypond.exe" 
>> D:\Data\lytest\test9.ly
>> and the first works but not the second.
>> btw: the problem isn't high priority for me because I'm running lilypond 
>> thru an interface which always redirects the output... but it's very strange
> I'm downloading 2.17.12 for Windows right now. I'll try to reproduce the
> bug.

Yes, I can reproduce this bug on an up to date Windows 7 64-bit using
lilypond 2.17.12.

The lilypond exe is launched, no GUI appears, and the program terminates
silently less than a second later.

After lilypond 2.17.12 has terminated in this way echo %errorlevel%
outputs 0 (i.e. the exit code was 0)

I tried 2.17.7 which I happened to have installed. It outputs the usage
message then terminates and it sets %errorlevel% to 2.

I'll create a tracker.


Colin Hall

reply via email to

[Prev in Thread] Current Thread [Next in Thread]