[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fedora lilypond will not compile with large character set fonts

From: Federico Bruni
Subject: Re: Fedora lilypond will not compile with large character set fonts
Date: Wed, 13 May 2015 19:42:55 +0200

added quickly:

Il giorno mar 12 mag 2015 alle 12:31, Andrew Bernard <address@hidden> ha scritto:
Hello Federico,

Thanks so much for this. If you did read my email, I explicit noted it works just fine on Debian. It is an issue specific to Fedora. There is no issue on Debian. And as mentioned, have you installed the Linus Libertine fonts, and tried this on Fedora? I can reproduce it on four Fedora machines.

It is only the downloadable 64 bit build running on Fedora 21 that shows the problem.

I have just moved to Fedora from Debian which is how I encountered the issue. I am sorry if this is not clear, but I did think I mentioned it.


On 12 May 2015 at 20:27:58, Federico Bruni (address@hidden) wrote:

Andrew, I'm Cc-ing the list again.

I can reproduce the warning after installing the package fonts-linuxlibertine and if I run lilypond with --verbose.
In Debian compilation is completed successfully.

Preprocessing graphical objects...
Grob count 43
Finding the ideal number of pages...
Fitting music on 1 page...
Drawing systems...
Element count 33
Layout output to `libertine-bugs.ps'...
Converting to `./libertine-bugs.pdf'...
Invoking `gs -dSAFER -dDEVICEWIDTHPOINTS=595.28 -dDEVICEHEIGHTPOINTS=841.89 -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite -sOutputFile=./libertine-bugs.pdf -c.setpdfwrite -flibertine-bugs.ps'...

GPL Ghostscript 9.15 (2014-09-22)
Copyright (C) 2014 Artifex Software, Inc. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
GPL Ghostscript 9.15: Can't embed the complete font LinLibertineO as it is too large, embedding a subset.
Success: compilation successfully completed

Il giorno mar 12 mag 2015 alle 11:57, Andrew Bernard <address@hidden> ha scritto:
Yes, the bug report shows that gs only issues a warning, and proceeds OK, but lilypond dies with a fatal error.

I forgot to add to the report that you must actually have the font installed for the error to occur - when lilypind falls back to a font with fewer characters when the font is missing there is no error.

This is my first bug report, so when it gets approved and into the tracking system, I will try to add the additional information. It’s only Fedora, I believe.


On 12 May 2015 at 19:49:00, Federico Bruni (address@hidden) wrote:

Ok, but did you try to run the gs command using the gs included in the binary package (i.e. version 9.06 instead of 9.15)?

Il giorno mar 12 mag 2015 alle 11:35, Andrew Bernard <address@hidden> ha scritto:
Yes. It is only on Fedora. Debian works fine.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]