[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Possible bug with new \partial

From: Simon Albrecht
Subject: Re: Possible bug with new \partial
Date: Sun, 16 Aug 2015 22:05:18 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.8.0

Hello Mats,

IIUC \partial serves to insert an additional amount of time, however in this example we actually need to skip a beat – thus call \partial with a negative duration, which is impossible :-) So you need to insert \set Timing.measureLength = #(ly:make-moment 3/4) before the second bar in your example. Is this documented differently? Else I wouldn’t consider it a bug, rather an inherent limitation.

Yours, Simon

Am 16.08.2015 um 21:28 schrieb Mats Bengtsson:

I tried version 2.19.25 to typeset a piece that changes from 4/4 with an upbeat to 3/4 without an upbeat, in the middle of the piece. The new \partial handling worked for all parts, except a part that started with a multimeasure rest. Here's a small example illustrating the problem. Uncommenting the \bar line makes things slightly better but still wrong.
\version "2.19.25"
\relative c'{
\time 4/4
\partial 4
c |
d e f g |
%\bar "||"
\partial 4*0
\time 3/4
R2.*3 |
f4 ( a f ) |
R2.*3 |


bug-lilypond mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]