[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Can't resize ext2 partition

From: Denny Fox
Subject: Can't resize ext2 partition
Date: Wed, 24 Oct 2001 08:45:08 -0500


I've used parted (1.4.9) very successfully to resize partitions on
many different hard disks. I've now got a hard disk that won't resize
with either version 1.4.9 or 1.4.20, using the parted boot disk(s).

The drive is an IBM Travelstar DADA-25120 in an HP Omnibook 5000
notebook. The drive C/H/S is 662/240/63. The system has 16mb ram and I
am running kernel 2.2.19.

parted p reports

geometry 662/240/63

Disk geometry for /dev/hda: 0.000 - 4887.421 megabytes
Disk label type: msdos

Minor   Start       End    Type  Filesystem  Flags
  1     0.031  2104.101  primary  ext2       boot
  2  2104.102  2170.546  primary  linux-swap

When I try

resize 1 0.031 2104.101         I get

VM: Killing process parted


This is the same for both versions of parted. Trying other values for
the END parameter gives the same result.

The system boots and runs Debian Linux (testing) just fine. It was
cloned from a system with "ghostpe" that had 1419520 1k blocks active
on a 2Gb partition, so the new system on the DADA-25120 only shows
1419520 1k blocks in a df -k. I had prepared the /dev/hda1 partition
with fdisk as 2.1Gb before the ghost process, with the expectation of
resizing the /dev/hda1 partition up to it's full size after ghosting
it. This has worked fine in the past with other drives.

I'm wondering if the head count of 240 is a problem?

Any help would be greatly appreciated!


Denny Fox

reply via email to

[Prev in Thread] Current Thread [Next in Thread]