[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: @footnote within @multitable is lost from TeX output

From: Stepan Kasal
Subject: Re: @footnote within @multitable is lost from TeX output
Date: Wed, 22 Jan 2003 14:48:45 +0100
User-agent: Mutt/


On Mon, Jan 20, 2003 at 05:10:44PM -0500, Karl Berry wrote:
> Unfortunately, I can't see any practical way to fix this.  Within TeX,
> the footnote is stored as a so-called insertion, and when it's used
> within another box, such as a @multitable, that insertion simply does
> not "migrate" out to the main vertical list where it would get typeset.
> So it disappears.  This all happens within the base TeX binary and is
> not controllable by macros :(.

> (Stepan or anyone, if you have any other suggestions...)

the following workaround is possible: inside @multitable, redefine
@footnote so that it doesn't create the insertion immediately but
saves the footnote text.  As soon as the current row is finished,
the saved footnote is converted to an insertion.

Patch attached: texinfo-multitable.patch
To be used with newest texinfo.tex from ftp://ftp.gnu.org/gnu/texinfo/

>     Shall i provide an example to reproduce the problem?
> In general yes, but in this case you already sent me the input on
> help-texinfo :).

OK, I've downloaded it, so I have a test material.
I've tested it with my code and it worked.

The table is not very nice, some rows seem to be closer then another ones.

But you have chance to go back and have only one copy of the table, if the
problem with spacing of rows is somehow solved.  (Insert blanks?)

I'm sure someone else will help you if you have problems with the spacing.

        Stepan Kasal

Attachment: texinfo-multitable.patch
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]