[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: weird @include problem under Cygwin

From: Ken Brown
Subject: Re: weird @include problem under Cygwin
Date: Wed, 21 Jan 2015 21:54:15 -0500
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.4.0

On 1/20/2015 1:06 PM, Per Bothner wrote:
I'm testing building Kawa (including kawa.info) using Cygwin, and
ran into this puzzling problem:

$ makeinfo -I . -o kawa.info kawa.texi
kawa.texi:123: @include: could not find version.texi
kawa.texi:130: warning: undefined flag: UPDATED

Line 123 is:
@include version.texi

Makeinfo can read version.texi directly:

$ makeinfo -o dummy.info version.texi
version.texi: warning: document without nodes

I've tried replacing the '-I .' with an explicit path - both Windows-style
(-I 'C:\Users\Per\Kawa\doc') and Cygwin-style (-I /cygdrive/c/Users/Per/doc).

I've also tried unix2dos and dos2unix to see if CRLF vs LF is a factor.

makeinfo --version reports 5.2.

Does this ring a bell with anyone?  Does anyone have experience with
running the new makeinfo under Cygwin on a file with @include?

I've done it without a problem, on both 32-bit and 64-bit Cygwin. Can you send a minimal example that fails for you?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]