[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Math styles

From: Hans Åberg
Subject: Re: Math styles
Date: Thu, 25 May 2017 23:11:39 +0200

> On 25 May 2017, at 21:41, Gavin Smith <address@hidden> wrote:
> I attach your input file as sample.texi.
> I thought I might have trouble running LuaTeX so first I tried it by
> deleting the lines from the file which used LuaTeX.  I've attached this
> as sample-fixed.texi.  Running TeX on this file went okay, apart from
> a few error messages:
> l.64: Unicode char @u8:  not defined for Texinfo
> l.64: Unicode char @u8:  not defined for Texinfo
> and so on.  

I can actually see the characters:

Writing index file sample.cp
l.69: Unicode char @u8:𝑨 not defined for Texinfo
l.69: Unicode char @u8:𝑩 not defined for Texinfo

> I didn't check them all, but I think these were for 
> characters in special typefaces like mathematical bold italic.  

Right, these styles are not defined in Texinfo, and the problem is that they 
are not in original TeX. These math styles were added to Unicode, and only some 
fonts support them. Traditionally, italic for variables and upright for 
constants, but not rigorously adhered to. In the past, bold italic was not 
commonly available, so one used upright bold instead.

> The 
> output looked OK apart from the missing math bold characters (no literal 
> @" in document and so on).  I tried this with the luatex command as well 
> as with pdftex and it looked okay each time.  Is that the case for you?

Yes, missing Unicode mathematical styles. It would be nice to able to index 
Unicode symbols, too. (See below.)

> I couldn't test the original file, presumably because my version of 
> LuaTeX is out of date.  

I use LuaTeX 0.95.0 (TeX Live 2016). There is LuaTeX 1.0 or later available 
from http://wiki.contextgarden.net/, but I haven't been able to run it 
standalone, only via ConTeXt.

> When I try running "luatex sample.texi", I get 
> the following:
> This is LuaTeX, Version beta-0.87.0 (TeX Live 2016/dev) 
> (./sample.texi (./luaotfload.sty
> ! I can't find file `ltluatex'.
> l.38   \input ltluatex
> (Press Enter to retry, or Control-D to exit)
> Please type another input file name: 

On my computer (MacOS 10.12.5):



The directory
contains several tens of files.

> Thus, there is probably no bug in Texinfo here, as it works when you
> don't load extra TeX code from other packages (which has never been 
> encouraged or guaranteed to work).  Obviously, if I can't reproduce
> the faulty output file with my setup, I can't investigate any deeper
> into what is happening here.

Texinfo probably works fine for the characters it knows to define a Unicode 
character for. Somehow, it might be extended to the Unicode mathematical styles.

>> It results in the error:
>>  String contains an invalid utf-8 sequence
>> There are some character translations causing this, it seems.
> I'd have to see the input file to know for sure, but one thing to check 
> is that your input is properly formed UTF-8.
> <sample.texi><sample-fixed.texi>

When I run another .texi file with
  @cindex ⇒
  @cindex ¬
luatex writes in the .cp file

Then texindex writes, last, perhaps it should be first, in the .cps file
  \initial {¬}
  \entry {¬}{18}
  \initial {‚}
  \entry {‚áí}{18}
Apparently, these contains malformed UTF-8, with the error below.

 String contains an invalid utf-8 sequence.
<read 1> \initial {
@body ...ttoken @relax @else @read 1 to @nextline 
                                                  @edef @act address@hidden 

@next ->@let @next address@hidden @body 
                                 @let @next address@hidden @fi @next 
@\printindex ... @let @thisline @nextline @repeat 
                                                  @enddoublecolumns @fi @fi ...

l.588 @printindex cp

reply via email to

[Prev in Thread] Current Thread [Next in Thread]