[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Building perldoc-all.info

From: Keith Thompson
Subject: Building perldoc-all.info
Date: Fri, 4 Jan 2019 10:12:40 -0800

I ran into some problems while building perldoc-all.info from the
contrib/perldoc-all directory.  I'm using the latest textinfo from
the git repo, with Perl 5.28.1.

The README file says:

    The idea is to unpack the perl distribution here, as in,
      wget http://www.cpan.org/src/5.0/perl-5.NN.M.tar.gz  # with right NN.M
      tar xf perl-*.tar.gz
    and run (GNU) make.  Aside from the result hopefully being useful in
    itself (just copy the .info file to an Info directory), it also serves
    as a nontrivial example of using pod2texi.

so I tried that.

make reported:
    Subroutine __ redefined at
/home/kst/git/texinfo/Pod-Simple-Texinfo/pod2texi.pl line 106.
I haven't figured out where the other definition is. I worked around
it by renaming "__" to "___:.

    rm -rf manual *.aux *.toc *.??

Removing "*.??" seems a bit aggressive. For example, it deleted the
perl-5.28.1.tar.xz file I had just downloaded and unpacked.

      gendocs.sh --email address@hidden --common "--no-warn
--no-validate" --split chapter --no-ascii --source perldoc-all --tex
"--batch -t @finalout" perldoc-all "Perl documentation in Texinfo"
    env: ‘gendocs.sh’: No such file or directory

There is no "gendocs.sh" script in the git repo. I found a copy in
gnulib. Copying it into the contrib/perldoc-all directory and changing
"gendocs.sh" to "./gendocs.sh" didn't work, because the script
was deleted by the GNUmakefile when it zapped *.sh, so I modified
GNUmakefile to refer to the directory where I downloaded gnulib.

After working around these problems, I managed to build
perldoc-all.info (and some other files).  After copying it to
"perl.info" in a directory in my $INFOPATH, I'm able to run
"info perl".  But when I search ("/") for "unlink" (which is in
section 26.2.3 "Alphabetical Listing of Perl Function") it didn't
find the occurrence I was looking for. It found an occurrence under
"PerlIO_tmpfile", but when I typed "/<enter>" to find it again,
it complained:

    Cannot find node '(perl)perlbook Other interesting, non-Perl books'

If you visit 4.2 "DESCRIPTION" (under "perlbook"), section 4.2.6
"perlbook Other interesting, non-Perl books" is unavailable. In
addition to that problem, it would be nice if info's search command
were able to skip over a missing node.

I do not suggest that this fixing this should be a high priority.

    -- Keith Thompson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]