[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building perldoc-all.info

From: Gavin Smith
Subject: Re: Building perldoc-all.info
Date: Tue, 29 Jan 2019 17:31:06 +0000
User-agent: Mutt/1.5.23 (2014-03-12)

On Fri, Jan 04, 2019 at 10:12:40AM -0800, Keith Thompson wrote:
> I ran into some problems while building perldoc-all.info from the
> contrib/perldoc-all directory.  I'm using the latest textinfo from
> the git repo, with Perl 5.28.1.

> make reported:
>     Subroutine __ redefined at
> /home/kst/git/texinfo/Pod-Simple-Texinfo/pod2texi.pl line 106.
> I haven't figured out where the other definition is. I worked around
> it by renaming "__" to "___:.

The other definition was in Texinfo::Common.

>     rm -rf manual *.aux *.toc *.??
> Removing "*.??" seems a bit aggressive. For example, it deleted the
> perl-5.28.1.tar.xz file I had just downloaded and unpacked.

Yes, this would have been to remove the index files that TeX reads and 
produces.  I've deleted the *.?? part of it.

>       gendocs.sh --email address@hidden --common "--no-warn
> --no-validate" --split chapter --no-ascii --source perldoc-all --tex
> "--batch -t @finalout" perldoc-all "Perl documentation in Texinfo"
>     env: ‘gendocs.sh’: No such file or directory
> There is no "gendocs.sh" script in the git repo. I found a copy in
> gnulib. Copying it into the contrib/perldoc-all directory and changing
> "gendocs.sh" to "./gendocs.sh" didn't work, because the script
> was deleted by the GNUmakefile when it zapped *.sh, so I modified
> GNUmakefile to refer to the directory where I downloaded gnulib.

I've added the script as "gendocs-sh".
> After working around these problems, I managed to build
> perldoc-all.info (and some other files).  After copying it to
> "perl.info" in a directory in my $INFOPATH, I'm able to run
> "info perl".  But when I search ("/") for "unlink" (which is in
> section 26.2.3 "Alphabetical Listing of Perl Function") it didn't
> find the occurrence I was looking for. It found an occurrence under
> "PerlIO_tmpfile", but when I typed "/<enter>" to find it again,
> it complained:
>     Cannot find node '(perl)perlbook Other interesting, non-Perl books'

It is due to the comma in the node name.  I spent some time trying to 
get pod2texi to omit this comma but didn't get anywhere with it.
That would be a low priority.

> If you visit 4.2 "DESCRIPTION" (under "perlbook"), section 4.2.6
> "perlbook Other interesting, non-Perl books" is unavailable. In
> addition to that problem, it would be nice if info's search command
> were able to skip over a missing node.

Yes, it probably should be able to skip missing nodes.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]