[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: error building classpath with gcj 3.3.5

From: Mark Wielaard
Subject: Re: error building classpath with gcj 3.3.5
Date: Mon, 23 May 2005 09:51:36 +0200

Hi Robert,

On Fri, 2005-05-20 at 04:00 +0200, Robert Schuster wrote:
> I am trying to build Classpath with GCJ 3.3.5 (actually gcj (GCC)
> 3.3.5-20050130 (Gentoo Linux, ssp-,
> pie- from the Gentoo distribution on x86) and it shows the
> following error:
> [...]
> ../gnu/java/rmi/ error: Class
> `' doesn't define the
> abstract method `double
> org.omg.CORBA.portable.InputStream.read_double()' from class
> `org.omg.CORBA.portable.InputStream'. This method must be defined or
> class `' must be declared
> abstract.
>    public class RMIMarshalledObjectInputStream extends RMIObjectInputStream
> (and many many more of this kind).
> As these errors do not happen with GCJ 4.0 I suppose the problem comes
> from a bug of the earlier GCJ versions. Do our GCJ people know about a
> problem where the compiler messed up the import functionality?

Have you tried 3.4?
Does this occur with or without the following patch?

2005-05-06  Mark Wielaard  <address@hidden>

        Reported by Kalle Olavi Niemitalo <address@hidden>.
        Workaround for gcj bug #21418
        * lib/ Set LC_ALL and LANG to C.
        Sort result of find.

That is from after the 0.15 release and someone told me it solved their
compile problem on gentoo.



Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]