[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "Outer world" encoding for non-Latin1 language environments

From: Eli Zaretskii
Subject: Re: "Outer world" encoding for non-Latin1 language environments
Date: Tue, 05 Mar 2002 19:28:19 +0200

> From: Anton Zinoviev <address@hidden>
> Date: Tue, 5 Mar 2002 12:57:39 +0200
> > > ^[%/1\200\212\koi8-r^B......
> > > 
> > > where dots are Latin-1 letters instead of Cyrillic.
> > 
> > The current CVS version and the pretest of Emacs 21.2 do support the
> > above.  Please try a newser version.
> Pasting from xterm in utf-8 mode works fine.  I think that pasting
> from koi8-r generates double-width Cyrillic letters from JISX0208
> instead of regular Cyrillic letters from ISO 8859-5.

That's strange: I thought compound-text decoded Cyrillic text into
cyrillic-iso8859-5 characters, not jisx0208 characters.

Are you sure you get jisx0208?  What does Emacs say if you go to one
of the Cyrillic characters you pasted and type "C-u C-x ="?  Please
post everything Emacs displays in the buffer it pops up.

> I tried rgrep koi8-r on sources and couldn't find where the clipboard
> support is located.  Where is it?

If you are looking for the support for ICCCM Extended Segments, it's
in mule.el, functions ctext-post-read-conversion and
ctext-pre-write-conversion (that's in CVS head; in the RC branch and
in the pretest 21.1.95, these functions are in mule-conf.el instead).

The rest of support for X selections is in xselect.c.

> The bug is in lisp/international/mule-cmds.el: Latin-5 is stated to be
> coding system for some of the Cyrillic locales.  However Latin-5 is
> actually ISO 8859-9 (quiet similar to Latin-1) and has nothing to do
> with ISO 8859-5 (Cyrillic-ISO).

Yes, you are right.  Please suggest what changes should be done in
locale-language-names for the Cyrillic locales.

> I observed a change between Emacs I used before and Emacs as I got it
> from CVS.  If I set the keyboard coding system apropriately, the
> previous version of Emacs worked fine both on the text-mode console
> and in X Window.  The last version of Emacs works in text-mode as well
> but in X Window it only beeps on non-ASCII symbols.

Please send more details about this problem; if you can debug this by
yorself, it would be even better.  I don't have any access to a
system in Cyrillic locale running X.

Is it possible that v21.1 that worked for you was compiled with XIM,
whereas the CVS version is not, or vice versa?  For XIM, the
locale-coding-system should be set correctly, or else non-ASCII input
will not DTRT.  Perhaps the same bug in mule-cmds.el that you
mentioned also affects this issue, as it sets the wrong
locale-coding-system given the value of LANG and LC_* environment

reply via email to

[Prev in Thread] Current Thread [Next in Thread]