[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Latest 21.3 CVS and MS Windows

From: Frank Schmitt
Subject: Latest 21.3 CVS and MS Windows
Date: Thu, 06 Feb 2003 09:25:59 +0100
User-agent: Gnus/5.090015 (Oort Gnus v0.15) XEmacs/21.5 (brussels sprouts, i586-pc-win32)


I just wanted to try Emacs 21.3 under MS Windows, therefor checked out
latest CVS but run into several problems:

First I tried to build using MS Visual C++ 6.0. I said "configure.bat
--with-ms-vc" and then said nmake but got an error message telling that
essential Lisp files would be missing and that I should either create
abbrev.elc somehow or run nmake bootstrap.

I then said "nmake bootstrap", this took ages but worked. I then said
"nmake install" however something seems to be broken about creation of
Info files because when i fire up info, I get the usual top node, but no
matter on which menu item I go, I get the error message "Info file foo
does not exist.". (There's no difference if I install Emacs where it's
build or if I give configure the --prefix foo option).

Then I wanted to try out the new external image library support, therefor
I got 

jpeg-6b-1-bin.zip   libpng-1.0.13-bin.zip   libpng-1.2.4-src.zip      
jpeg-6b-1-lib.zip   libpng-1.0.13-lib.zip   libungif-4.1.0b1-bin.zip  
libjpeg-6b-bin.zip  libpng-1.2.4-1-bin.zip  libungif-4.1.0b1-lib.zip  
libjpeg-6b-lib.zip  libpng-1.2.4-1-lib.zip  libungif-4.1.0b1-src.zip  
zlib-1.1.4-bin.zip  zlib-1.1.4-lib.zip

from gnuwin32.sourceforge.net, unziped the files, added the include
directory to $INCLUDE and the bin directory to $PATH and repeated the
cycle from above. Configure found all external libraries except the gif
libraries and nmake gave me an Emacs which was able of displaying
XPM's. However (image-type-available-p 'tif) (or 'tiff) evaluates to
nil, as well as configure said it found the necessary libraries, trying
to display a jpeg results in an empty square of the size of a character
and trying to display a png makes Emacs crash, no matter if I use
libpng-1.2.4 or libpng-1.0.13.

So I thought "MS-VC build seems to be somehow broken, let's try it with
Cygwin's gcc" 

I said
./configure.bat --with-gcc --no-cygwin --cflags 
which worked

but saying make (or make bootstrap) results in

[Please ignore a syntax error on the next line - it is intentional]
Syntax error: Unterminated quoted string
Using /bin/sh.exe as shell.
gcc -o oo-spd/i386/addpm.exe \
           -g -mno-cygwin  oo-spd/i386/addpm.o   -ladvapi32 -luser32
/usr/lib/gcc-lib/i686-pc-mingw32/3.2/../../../../i686-pc-mingw32/bin/ld: cannot 
open crt2.o: No such file or directory
make: *** [oo-spd/i386/addpm.exe] Error 1

Reducing the configure options to --with-gcc doesn't help, I get the
same error.

My environment: Full install of up-to-date Cygwin, Cygwin bin dirs in
global $PATH,Latest Emacs CVS head, MS Visual C++ (all patches), Cygwin
make 3.79.1, Cygwin gcc 3.2, Windows XP SP1.

However after so much trouble, there's also joy: Damned, Emacs is FAST!
I'm using XEmacs 21.5 at the moment and even if I disable all debugging
when building XEmacs it is unbelievable much slower. I'm not talking
about Emacs being 10 or 20% faster, when I run Gnus in both and stop the
time for e.g. entering a large group I'm talking about Emacs being 3-4
times (sic!) faster. This is incredible, and it's a major pain for me
now to return to this sluggish XEmacs, so I would be really grateful, if
you could help me to get Emacs 21.3 up and running. (I need (want) the
external image library support of 21.3, because I want to display XFaces
and Faces headers and use preview-latex).

MFG Frank

One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the Land of Mordor where the Shadows lie.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]