[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest 21.3 CVS and MS Windows

From: Frank Schmitt
Subject: Re: Latest 21.3 CVS and MS Windows
Date: Thu, 06 Feb 2003 19:18:50 +0100
User-agent: Gnus/5.090015 (Oort Gnus v0.15) XEmacs/21.5 (brussels sprouts, i586-pc-win32)

Juanma Barranquero <address@hidden> writes:

> On Thu, 06 Feb 2003 09:25:59 +0100, Frank Schmitt <address@hidden> wrote:
>> First I tried to build using MS Visual C++ 6.0. I said "configure.bat
>> --with-ms-vc"
>  --with-msvc, I suppose.

Yes, of course.

>> and then said nmake but got an error message telling that
>> essential Lisp files would be missing and that I should either create
>> abbrev.elc somehow or run nmake bootstrap.
>> I then said "nmake bootstrap", this took ages but worked.
> That's the right procedure. First time you *must* do a bootstrap.

Shouldn't this be mentioned in section Building of nt/INSTALL?

>> I then said
>> "nmake install" however something seems to be broken about creation of
>> Info files because when i fire up info, I get the usual top node, but no
>> matter on which menu item I go, I get the error message "Info file foo
>> does not exist.".
> Is not broken, it's simply not supported, because most Windows users
> don't have the tools to build info files. You can get a working makeinfo
> from http://www.simtel.net/pub/djgpp/v2gnu/ (get txi42b.zip) and
> manually build the info files (that's what I do). If you get make errors
> try taking Cygwin bin directory from the PATH.

OK, I'll do so. However, wouldn't it be nice if configure.bat checked if
Makeinfo is available and if it is change the Makefile accordingly?

> There are some interactions between the libraries (libtiff.dll needs
> libjpeg.dll, etc.), and not all releases work well togheter. I'm using:
>  libjpeg-6b (includes librle.dll)
>  libpng-1.2.4-1
>  libungif-4.1.0b1
>  tiff-3.5.7
>  xpm-3.4k-1
>  zlib-1.1.4
> (from GnuWin32) which seem to be nice with each other.

I had libjpeg-6b-1 and missed librle.dll (it's not included there). With
the above configuration everything is fine, except that
libungif-4.1.0b1-lib.zip doesn't include gif_lib.h, after I copied it
from the src package to gnuwin32/include all libraries were found and
Emacs build OK.

>> trying to display a jpeg results in an empty square of the size of a 
>> character
> When that happened to me, it was the result of a mismatch between the
> libraries (a libjpeg.dll that couldn't find the corresponding librle.dll).

Works now, I had missed librle.dll.

>> and trying to display a png makes Emacs crash, no matter if I use
>> libpng-1.2.4 or libpng-1.0.13.
> That's probably a bug. Were you compiling Emacs with optimizations?
> Currently, images work well for me with MSVC 6.0 and --no-opt, but I get
> crashes with TIFF and PNG files when optimization is enabled.

Yes, I had optimization enabled which resulted in a crash whenever I
tried to display a png or tiff file. If I build without optimization, the
crashes are gone.

> Don't forget that image support on Windows is still experimental. Any
> information you can gather about the crashes could be useful.

I'll build one more Emacs in a different directory with optimization and
try to debug where the crash occurs.

Thanks for now for your help, I now seem to have everything running. Now
I /only/ have to transfer my configuration from XEmacs to Emacs :-).

One Ring to rule them all, One Ring to find them,
One Ring to bring them all and in the darkness bind them
In the Land of Mordor where the Shadows lie.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]