[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

utf-translate-cjk-mode question

From: Kai Großjohann
Subject: utf-translate-cjk-mode question
Date: Mon, 21 Apr 2003 20:01:40 +0200
User-agent: Gnus/5.090019 (Oort Gnus v0.19) Emacs/21.3.50 (gnu/linux)

I have some questions about utf-translate-cjk-mode -- I think it
might not be working, so I'm trying to understand it.  I probably
b0rked it when I changed it to use define-minor-mode.  It's rather
embarrassing :-/

In my ~/.emacs file, I have this piece of code:

(when (fboundp 'utf-translate-cjk-mode)
  (let ((current-language-environment "Chinese-GB"))
    (utf-translate-cjk-mode 1)))

I start Emacs.  I open a new file.  I say C-u C-\ chinese-py RET.  I
then type "nihao" into the buffer.  I say C-x RET f utf-8 RET.  Then
I try to save the buffer.

Emacs tells me that it can't encode the Chinese characters, and it
tried iso-latin-1 and utf-8 as encodings, and now it's suggesting
gb2312 as the encoding to use.

Is utf-translate-cjk-mode supposed to enable me to store the file as

The second question contains the code itself.  I tried to just copy
and paste it from the original defcustom.  But maybe I did something
wrong.  After loading all the subst-foo files, there is a let
statement that binds the symbol `table'.  But after this, nothing is
done with that symbol -- it does not appear to be accessed after
being populated.  I also looked in version 1.27 (the last version
before my change), and there, too, the symbol `table' does not appear
to be accessed.

What is going on here?  Is there some kind of magic?

I have the nagging feeling that the `table' needs to be passed to
define-translation-table somehow, but I can't find the code that used
to do that.

file-error; Data: (Opening input file no such file or directory ~/.signature)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]