[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: utf-translate-cjk-mode question

From: Kai Großjohann
Subject: Re: utf-translate-cjk-mode question
Date: Fri, 25 Apr 2003 15:59:38 +0200
User-agent: Gnus/5.090019 (Oort Gnus v0.19) Emacs/21.3.50 (gnu/linux)

address@hidden (Kai Großjohann) writes:

> In my ~/.emacs file, I have this piece of code:
> (when (fboundp 'utf-translate-cjk-mode)
>   (let ((current-language-environment "Chinese-GB"))
>     (utf-translate-cjk-mode 1)))
> I start Emacs.  I open a new file.  I say C-u C-\ chinese-py RET.  I
> then type "nihao" into the buffer.  I say C-x RET f utf-8 RET.  Then
> I try to save the buffer.
> Emacs tells me that it can't encode the Chinese characters, and it
> tried iso-latin-1 and utf-8 as encodings, and now it's suggesting
> gb2312 as the encoding to use.

I've now tried (encode-coding-region (point-min) (point-max) 'utf-8)
on that buffer.  This produces \344\275\240\345\245\275 which I guess
might be right (but I didn't check).

So why can Emacs encode the buffer into UTF-8 but can't save the
buffer in UTF-8 encoding?

coding-category-list contains coding-category-utf-8 as the last

I'm quite confused now.
file-error; Data: (Opening input file no such file or directory ~/.signature)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]