[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unwanted undo-boundary

From: Lennart Borgman
Subject: Re: Unwanted undo-boundary
Date: Sun, 14 Feb 2010 01:30:21 +0100

On Sat, Feb 13, 2010 at 7:54 PM, Stefan Monnier
<address@hidden> wrote:
>> I just got a bug report saying that a single indent-region in mumamo
>> can't be undone with a single undo command. (This is with the latest
>> nXhtml beta and I can confirm it with an Emacs from 2010-02-03.)
>> I assume this means that something is calling undo-boundary, but I
>> can't find out what. There is nothing in nXhtml that does it. (Yes,
>> one function does, but it is not involved here.) I tried to trace
>> undo-boundary, but I get no hit.
>> Does anyone have a good idea for how to find out what is happening? Am
>> I wrong assuming that undo-boundary have been called (implicitly or
>> explicitly)?
> It's hard to tell without more info, but yes if more than a single undo
> is needed, it's probably because of a call to undo-boundary, tho it
> might come from the C code (which you wouldn't be able to trace from
> Elisp, you'd need to put a breakpoint on Fundo_boundary from gdb).

I have not done that (yet), but looking at the where Fundo_boundary is
called I see that there is a check like this

 if (current_buffer != last_undo_buffer)
    Fundo_boundary ();
  last_undo_buffer = current_buffer;

in some places. In my case changes in two buffers are involved. (One
is just to figure out the indentation.)

I just did a fresh checkout and tried "gdb emacs" but got:

  .gdbinit:23: Error in sourced command file:
  No symbol table is loaded.  Use the "file" command.

Is this expected? For configure I have used (on w32):

    cmd /c configure --with-gcc --no-opt --cflags -Ic:/g/include
--cflags -fno-crossjumping

> Maybe if you look at the place where the undo stops, you'll get some
> hint at the culprit,
>        Stefan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]