[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unwanted undo-boundary

From: Lennart Borgman
Subject: Re: Unwanted undo-boundary
Date: Sun, 14 Feb 2010 09:20:30 +0100

On Sun, Feb 14, 2010 at 5:14 AM, Eli Zaretskii <address@hidden> wrote:
>> From: Lennart Borgman <address@hidden>
>> Date: Sun, 14 Feb 2010 01:30:21 +0100
>> Cc: Johan Andersson <address@hidden>,
>>       Emacs-Devel devel <address@hidden>
>> I just did a fresh checkout and tried "gdb emacs" but got:
>>   .gdbinit:23: Error in sourced command file:
>>   No symbol table is loaded.  Use the "file" command.
>> Is this expected?
> No.  Does it help to say "gdb emacs.exe" instead?  (Btw, I assume you
> actually did something like "gdb /path/to/emacs.exe", like, for
> example, "gdb ./oo-spd/i386/emacs", because normally emacs.exe is not
> in the src subdirectory, where you find .gdbinit.)

No, I just did what etc/DEBUG says which is

   dbg emacs

Since I do these things so seldom I am dependent on that this is correct.

I just tried

   dbg PATH-TO/emacs.exe

and got

   GNU gdb 5.2.1
   Copyright 2002 Free Software Foundation, Inc.
   GDB is free software, covered by the GNU General Public License, and you are
   welcome to change it and/or distribute copies of it under certain conditions.
   Type "show copying" to see the conditions.
   There is absolutely no warranty for GDB.  Type "show warranty" for details.
   This GDB was configured as
gdb-internal-error: read_comp_unit_head: dwarf from non elf file

   An internal GDB error was detected.  This may make further
   debugging unreliable.  Quit this debugging session? (y or n)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]