[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Proposal: 'struct window' cleanup

From: Dmitry Antipov
Subject: Re: Proposal: 'struct window' cleanup
Date: Tue, 22 May 2012 11:08:18 +0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20120428 Thunderbird/12.0.1

On 05/22/2012 07:30 AM, Stefan Monnier wrote:

I generally like the idea.  But please don't use "_p" suffixes
for variables.  The "p" stands for "predicate" and a predicate is a kind
of function, so that's not the right way to say that something is
a boolean value.

OK,  but what about other "struct window" bitfield members whose names
ends with "_p"? Should we also rename it to obey this naming convention?

Also this kind of patch proposes a lot of small and simple changes.
Is there a convenient way to document them in ChangeLog?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]