[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building Emacs for GNUstep

From: Jan Djärv
Subject: Re: Building Emacs for GNUstep
Date: Wed, 09 Jul 2014 11:34:23 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0


2014-07-09 04:25, Stefan Monnier skrev:

I just tried to build Emacs for GNUstep under Debian (from trunk).
The configure and build worked smoothly, but when I try to run the
executable I get a seg-fault:

    Program received signal SIGSEGV, Segmentation fault.
    0xf76e905f in objc_msg_lookup () from /usr/lib/i386-linux-gnu/libobjc.so.4
    (gdb) bt
    #0  0xf76e905f in objc_msg_lookup () from 
    #1  0x081e8028 in x_set_window_size (f=0x877a0d0, change_grav=142057680,
        width=14, height=70, pixelwise=120) at nsterm.m:1382
    #2  0x00000000 in ?? ()

    Lisp Backtrace:
    "x-create-frame" (0xffffcb28)
    "x-create-frame-with-faces" (0xffffccb8)
    "make-frame" (0xffffce48)
    "frame-initialize" (0xffffcfd8)
    "command-line" (0xffffd1ac)
    "normal-top-level" (0xffffd310)

Any idea what might be going on?

This usually indicates that an object has been deallocated.
I.e. x_set_window_size is being called on a frame where the NSView is deallocated or garbage (not null, there is a test for that).
Your backtrace indicates that view is the culprit.  In gdb, you can
(gdb) po view
to print it as an Obj-C object.

Is it indeed a live frame? You did start nextstep/Emacs.app/Emacs, and not src/emacs?

I can't reproduce it here (trunk or 24).
I have found that GNUStep behaves very different depending on version and on what GNU/Linux distribution you are using. For example, on Fedora and Mint, I have the same GNUStep version. But Fedora has numerous font related problems that does not exist on Mint, but Mint sometimes produce the wrong font metrics for characters, something Fedora does not.

        Jan D.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]