[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Feature Request: Function to quote filenames

From: T.V Raman
Subject: Re: Feature Request: Function to quote filenames
Date: Wed, 24 Jun 2015 13:24:27 -0700

Thanks Stefan -- In this instance, I went back and looked in the
buffer on my laptop where I hit the error -- like you said I had used
the result from shell-quote-argument  incorrectly -- had used
"... '%s'" and  the "'%s'" was the cause of the breakage.

Stefan Monnier writes:
 > > interesting, it worked for me just now -- not sure why I hit an error
 > > when I last tried. I likely did somethign else that messed it up -- --
 > > but in general, I've had trouble with quoting arguments from elisp to
 > > the shell.
 > Quoting is tricky business, and it's easy to mess it up. But details
 > matter, and in most cases the problem is not that shell-quote-argument
 > doesn't work right, but that it's not called on the right data, or it's
 > not called at all, or the result is then later massaged incorrectly,
 > etc...
 > Once you have a concrete problem case, file a bug report.
 >         Stefan



reply via email to

[Prev in Thread] Current Thread [Next in Thread]