[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ./guile-config : permission denied

From: Jon Wilson
Subject: Re: ./guile-config : permission denied
Date: Fri, 01 Dec 2006 10:14:02 -0600
User-agent: Thunderbird (X11/20061115)

Hi Gopi,
Are you sure that the execute permissions are set for the guile-config executable? Check this with ls -l /path/to/guile-config . It should look something like

$ ls -l /usr/local/bin/guile-config
-rwxr-xr-x 1 root root 9110 2006-11-30 10:00 /usr/local/bin/guile-config

The gibberish at the beginning of the line is the permissions. r is read, w is write, x is execute. The first rwx is for the owner of the file (root in this case), the second r-x is for any user in the group (root) that owns the file, and the third r-x is for all other users. That initial - is for a few special things, like marking directories.

If you lack the x on the third set of permissions, then most users will not be able to execute guile-config, and in fact it will fail with just the error message you received. If you lack the x on all three sets of permissions, then nobody (yes not even root) will be able to execute guile-config.

You can change the permissions with chmod (1).  Try

$ chmod a+x /path/to/guile-config

This will set the execute bit for owner, group, and others, that is, for all three permissions categories. It will leave the read and write bits unchanged.


Gopi kumaran wrote:
when i run ./configure in guile-1.8.1 it stops by saying
checking for guile...guile-config:permission denied
configure:cannot find guile-config;is Guile installed?
wht to do?I went to /usr/local/bin(i assume that it will check in this folder).i tried to run ./guile-config in /usr/local/bin/guile-config folder it says
./guile-config:permission denied
I changed to su and then tried but still same problem
Any help

Everyone is raving about the all-new Yahoo! Mail beta. <*>

Guile-user mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]