[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile-2.0.11 installation on system with 2.0.5

From: David Pirotte
Subject: Re: guile-2.0.11 installation on system with 2.0.5
Date: Tue, 16 Sep 2014 15:16:34 -0300


> ...
> OK, I've found out by using "apt-cache policy package-name": I need to
> lower the default priorities of packages from testing other than guile
> with
> Package: *
> Pin: release o=Debian
> Pin-Priority: 10

good to know, tx!

> Now I do not get other packages with "aptitude full-upgrade", but if I
> pull in guile-2.0 from testing it wants to change several other
> libraries:

yes, this is to be expected indeed, as guile-2.0-libs, in testing, depends on
libgc1c2 >= 7.2d, which triggers a series of dependency updates.

i am actually _very_ surprised that this would not be the case when manually
installing guile-2.0.11: I thought configure would not let you install unless 

note also that guile-2.0-dev is not required, not sure it is the 'full-upgrade'
terribly scary beast that triggered that?

> $ sudo aptitude -t testing full-upgrade guile-2.0
> The following NEW packages will be installed:
>   libffi6{a}
> The following packages will be upgraded:
>   guile-2.0 guile-2.0-libs libc6 libgc1c2 libgssapi-krb5-2
> libk5crypto3 libkeyutils1
>   libkrb5-3 libkrb5support0 libtirpc1 locales nfs-common
> 12 packages upgraded, 1 newly installed, 0 to remove and 1353 not upgraded.
> Need to get 12.1 MB of archives. After unpacking 2,553 kB will be used.
> The following packages have unmet dependencies:
>  krb5-user : Depends: libkrb5-3 (= 1.10.1+dfsg-5+deb7u2) but
> 1.12.1+dfsg-9 is to be installed.
>  libgc-dev : Depends: libgc1c2 (= 1:7.1-9.1) but 1:7.2d-6.3 is to be 
> installed.
>  libc6-i386 : Depends: libc6 (= 2.13-38+deb7u4) but 2.19-11 is to be 
> installed.
>  guile-2.0-dev : Depends: guile-2.0 (= 2.0.5+1-3) but 2.0.11+1-1 is to
> be installed.
>  libc6-dev : Depends: libc6 (= 2.13-38+deb7u4) but 2.19-11 is to be installed.
>  libc-dev-bin : Depends: libc6 (< 2.14) but 2.19-11 is to be installed.
> I think I will just install guile 2.0.11 "manually".

It should request you to update libgc1c2 as well, and actually constraints 
might even
be stronger [when the tarball is >=, in version, to the 1 used by debian pkg

Hum, mark, ludovic,  am I wrong here?


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]