[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

--listen option broken on Mac

From: Matthew Keeter
Subject: --listen option broken on Mac
Date: Sun, 27 Dec 2015 20:06:46 -0500

Hi Guile-folks,

I’m having trouble with the --listen option on Guile 2.0.11, Mac OS 10.9.5.

I start up one REPL with “guile --listen”, then connect with “nc localhost 
The netcat window immediately fills with (repeating over and over):

    scheme@(guile-user)> While reading expression:
    ERROR: In procedure fport_fill_input: Resource temporarily unavailable

When I kill the nc process, the REPL crashes with "fport_write: Broken pipe”

I’ve tried running this on a Linux VM and it works fine.

Per discussions on IRC, I tried to run the test suite.  However, the test suite 
with the message

    ERROR: In procedure scm-error:
    ERROR: no code for module (test-suite lib)

Any suggestions on how to proceed?  Can anyone else on a Mac confirm this issue?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]