[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [h-e-w] Problems with gnuserv in XP

From: Guy Gascoigne-Piggford
Subject: RE: [h-e-w] Problems with gnuserv in XP
Date: Tue, 24 Sep 2002 10:01:35 -0700

Blast :-(

Do either of you have DevStudio installed?  If so I could get you the source
and build instructions (only takes a couple of minutes) and you could try
running the debug version and attaching the debugger to it and see where it
thinks its hanging?  I'm guessing that one of the server threads is getting
hung up but I just can't get it to break here.  I've never run into problems
where it executes differently outside of emacs to the way it does inside

If that doesn't work I guess I could add some logging and get you a
different build and we could try that.


-----Original Message-----
From: Eli Daniel [mailto:address@hidden 
Sent: Tuesday, September 24, 2002 7:09 AM
To: address@hidden; address@hidden
Cc: address@hidden
Subject: RE: [h-e-w] Problems with gnuserv in XP

I had exactly the same experience.  Gnuserv does indeed start when I
start emacs.  If emacs launches as a result of doing a gnuclient
command, then a message appears in the *server* buffer and the file
opens correctly.  Once emacs is open, however, running gnuclient causes
no message to appear in the server buffer and no file to open.

Running gnuserver outside of emacs, everything works just fine.

Guy, do you have any thoughts on how to debug this?


-----Original Message-----
From: address@hidden
[mailto:address@hidden On Behalf Of Fredrik Oberg
Sent: Sunday, September 22, 2002 2:52 PM
To: address@hidden
Subject: RE: [h-e-w] Problems with gnuserv in XP

and thanks for all input. How ever, things still doesn't 
work as expected...

> 1) After running emacs, open the task manager and check that
> gnuserv is actually running, what you describing sounds like
> its exited.

Hate to tell you, but it is running..

> 2)  Try running the tools outside of emacs.


I followed your detailed instruction and everything worked 

> 2) If that worked then you should be able to run inside
> emacs.
> In you .emacs file you can also add the line:
>   (get-buffer-create "*server*")
> before the line saying 
>   (require 'gnuserv)

Ok, if I use runemacs, the *server* buffer says nothing, 
and emacs and gnuserv is in the taskmanager.

If I use my sendto shortcut, after opening the first file, 
the *server* buffer says:

1928 (server-edit-files-quickly '((1 . 

The taskmanager says that emacs and gnuserv is running. 

When trying to send another file to emacs, nothing happens 
in emacs, but there is a gnuclientw process in taskmanager. 
Looks like the process is waiting for gnuserv to take over, 
but gnuserv never does... Any more clues...?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]