[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: escape characters in emacs20 shell mode

From: Daniel Jensen
Subject: Re: escape characters in emacs20 shell mode
Date: Thu, 14 Nov 2002 13:11:27 +0100
User-agent: Gnus/5.090007 (Oort Gnus v0.07) Emacs/21.2 (i686-pc-linux-gnu)

Nimar Arora <> writes:

> I'm running emacs20 on a Linux (Debian - Woody/stable)
> virtual console. When I enter an emacs shell and try
> to execute some command - like 'ls' - the output
> contains a whole of junk - [[0m etc. These look like
> the escape characters which can control the display
> attributes on some terminals. I don't understand why
> I'm getting these. I don't even have a .emacs file
> yet, so I haven't changed the default configuration.

Try putting this in your .emacs:

(require 'ansi-color)
(setq ansi-color-for-comint-mode t)

Or, use eshell instead.

> I tried, 'E-x shell-strip-ctrl-m' but to no avail. I
> also tried to lookup the info on Emacs shell mode to
> see if Debian has created some funky shell mode but
> couldn't find anything.

shell-strip-ctrl-m doesn't remove those color escape codes. It does
exactly what the name suggests, removes ^M's from output.

Daniel Jensen
: (format (concat "mailto:"; "%s@%s.%s") "daniel" "bigwalter" "net")

reply via email to

[Prev in Thread] Current Thread [Next in Thread]