[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Setting up plug and print on GuixSD?

From: Ludovic Courtès
Subject: Re: Setting up plug and print on GuixSD?
Date: Tue, 02 Feb 2016 13:57:29 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)

address@hidden skribis:

> On 2016-02-02 11:45, address@hidden wrote:
>> On 2016-02-01 14:43, address@hidden wrote:
>>> address@hidden skribis:
>>>> I installed cups and xfce. What more do I need?
>>> For printers available on the network as in a typical “enterprise”
>>> setup, nothing more: the “print” dialog in Evince and similar tools
>>> will
>>> discover it and do the right thing.
>>>> In
>>>> I did not find a service declaration for CUPS.
>>>> What is the next step?
>>> For a locally-connected printer you’ll certainly need a CUPS daemon
>>> running, indeed.  I’m not sure exactly what it takes, but it would
>>> clearly be a worthwhile addition!
>> OK. I gave it a try and this is how far I got:
>> The manpages and documentation on is rather useless regarding
>> installation and formatting of the config-files.
>> The package installs corrupt config-files according to
>> $ cupsd -t
>> "/gnu/store/qs3xymcsgxa68i8m188261rhxsszx7za-cups-2.1.0/etc/cups/cups-files.conf"
>> contains errors.

Yeah, I have the same error, which is interesting given that this file
comes straight from upstream.

>> I have a running working installation of cups 1.7 on my trisquel 7
>> machine. I tried copying the working (very similar) configs from there
>> which the trisquel-cupsd report as 'OK'.
>> => It did not help and the error is not as detailed as I would like
>> and there is no debug option is seems.
>> Is there a good free non-apple-owned alternative to CUPS I could try
>> instead?
> The cupsd.conf I tried is attached. I now also tried this as root and
> testing with cupsd afterward without any succes:
> cp -r /gnu/store/qs3xymcsgxa68i8m188261rhxsszx7za-cups-2.1.0/var/* /var/

I see that our CUPS is *not* built with --localstatedir=/var, so it will
try to access and maybe modify stuff in /gnu/store/…-cups-2.1.0, which
is not good.  We should fix it.

In the meantime, you can run:

  cupsd -c /path/to/your/cupsd.conf

(It’s still won’t be able to write its log files, though, since it’ll
want to write them to /gnu/store, which is immutable on GuixSD.)

> Maybe the error is that the socket referenced in cupsd.conf is missing:
> "# Only listen for connections from the local machine.
> Listen localhost:631
> Listen /var/run/cups/cups.sock"
> The socket is missing in the store and from the path above. I have no
> idea yet how to create it manually.

It’s probably enough to do “mkdir -p /var/run/cups”, but I’m not sure
this named socket is actually used.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]