[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Running "guild" runs a script in one of my projects

From: sirgazil
Subject: Re: Running "guild" runs a script in one of my projects
Date: Wed, 12 Feb 2020 08:52:45 -0500
User-agent: Zoho Mail

 ---- On Wed, 12 Feb 2020 02:18:43 -0500 Jeremy Korwin-Zmijowski 
<address@hidden> wrote ----
 > Le lundi 10 février 2020 à 14:20 -0500, sirgazil a écrit :
 > > Hi,
 > > 
 > > Trying to learn about "guild" (a tool that comes with Guile), I ran
 > > "guild --help" and noticed something strange: the usage information
 > > is displayed, and immediately after that a script in one of my Guile
 > > projects is run, so I see the output of that script as well. Running
 > > "guild" alone does the same. It doesn't matter where in my home
 > > directory I run "guild", I get the same results.
 > > 
 > > Any idea what could this be?
 > > 
 > > 
 > > ---
 > >
 > > 
 > > 
 > > 
 > Hello Sirgazil !

Hi Jérémy :)

 > Here are two commands I just tried and I don't have this behavior on my
 > system (Ubuntu).

I forgot to say I'm using the Guix System with this guix:

$ guix describe
Generation 36   Feb 11 2020 11:04:57    (current)
  sirgazil-x 8364c4d
    repository URL: address@hidden:sirgazil/guix-channel-x.git
    branch: master
    commit: 8364c4df64c5aabd25751a6297e8463a50cd7c2c
  guix 4835f86
    repository URL:
    branch: master
    commit: 4835f862925e8aa06b7e23d5dd5d08ceb25a02dc

 >    $ guild --version
 >    guild (GNU Guile) 2.2.6
 >    Copyright (C) 2019 Free Software Foundation, Inc.
 >    License LGPLv3+: GNU LGPL 3 or later <
 >    This is free software: you are free to change and redistribute it.
 >    There is NO WARRANTY, to the extent permitted by law.

This one works fine for me; I get the same output as you.

 >    $ guild --help
 >    Usage: guild COMMAND [ARGS]
 >    Run command-line scripts provided by GNU Guile and related programs.
 >    Commands:
 >      compile              Compile a file.
 >      disassemble          Disassemble a compiled .go file.
 >      display-commentary   Display the Commentary section from a file or
 >    module.
 >      doc-snarf            Snarf out documentation from a file.
 >      help                 Show a brief help message.
 >      use2dot              Print a module's dependencies in graphviz
 >    format.
 >    For help on a specific command, try "guild help COMMAND".
 >    Report guild bugs to address@hidden
 > GNU Guile home page: <>
 > General help using GNU software: <>
 > For complete documentation, run: info '(guile)Using Guile Tools'

In my case, I get the same output until the "doc-snarf" line (inclusive). The 
rest of the information is replaced by the output of a script I have in one of 
my project folders.

Could someone using the Guix System check if they can reproduce this problem, 

Thanks for checking, Jérémy.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]