[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Running "guild" runs a script in one of my projects

From: Jeremy Korwin-Zmijowski
Subject: Re: Running "guild" runs a script in one of my projects
Date: Wed, 12 Feb 2020 08:18:43 +0100

Le lundi 10 février 2020 à 14:20 -0500, sirgazil a écrit :
> Hi,
> Trying to learn about "guild" (a tool that comes with Guile), I ran
> "guild --help" and noticed something strange: the usage information
> is displayed, and immediately after that a script in one of my Guile
> projects is run, so I see the output of that script as well. Running
> "guild" alone does the same. It doesn't matter where in my home
> directory I run "guild", I get the same results.
> Any idea what could this be?
> ---

Hello Sirgazil !

Here are two commands I just tried and I don't have this behavior on my
system (Ubuntu).

   $ guild --version
   guild (GNU Guile) 2.2.6
   Copyright (C) 2019 Free Software Foundation, Inc.

   License LGPLv3+: GNU LGPL 3 or later <>.
   This is free software: you are free to change and redistribute it.
   There is NO WARRANTY, to the extent permitted by law.
   $ guild --help
   Usage: guild COMMAND [ARGS]
   Run command-line scripts provided by GNU Guile and related programs.

     compile              Compile a file.
     disassemble          Disassemble a compiled .go file.
     display-commentary   Display the Commentary section from a file or
     doc-snarf            Snarf out documentation from a file.
     help                 Show a brief help message.
     use2dot              Print a module's dependencies in graphviz

   For help on a specific command, try "guild help COMMAND".

   Report guild bugs to address@hidden
GNU Guile home page: <>
General help using GNU software: <>
For complete documentation, run: info '(guile)Using Guile Tools'



reply via email to

[Prev in Thread] Current Thread [Next in Thread]