[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Client fails to find package (mame) with guix publish

From: Pierre Neidhardt
Subject: Re: Client fails to find package (mame) with guix publish
Date: Tue, 18 Feb 2020 12:57:31 +0100

Efraim Flashner <address@hidden> writes:

> On Tue, Feb 18, 2020 at 12:31:39PM +0100, Pierre Neidhardt wrote:
>> Hi!
>> The 'mame' package is not available on for some reason,
>> so I did build it locally on my desktop.
>> Now I'd like to transfer this build artifact to my laptop.
>> On my desktop I ran
>> --8<---------------cut here---------------start------------->8---
>> sudo guix archive --generate-key
>> sudo guix publish 
>> --8<---------------cut here---------------end--------------->8---
> did you transfer the public key to your other machine and run 'sudo guix
> archive --import < /path/to/public/key'?

That was it, I had forgotten to import the public key!

By the way, it's

--8<---------------cut here---------------start------------->8---
sudo guix archive --authorize < /path/to/public/key
--8<---------------cut here---------------end--------------->8---

not `--import` :)

> Try giving it a few minutes to "bake" the substitute and then serve it.
> It needs to re-compress it to make transfers (at a large scale) more
> economical.

I didn't enable caching so the compression should happen on the fly.

> Doesn't address the substitute/publish problem, but have you tried using
> guix copy to copy it over?

I haven't but I want to use `guix publish` since it provides a more
automated, smoother experience.

Problem solved, thanks!
Pierre Neidhardt

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]