[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: meson needs certain version

From: Fredrik Salomonsson
Subject: Re: meson needs certain version
Date: Tue, 10 Aug 2021 01:20:56 +0000


Andy Tai <> writes:

> Hi, I am trying to create package definition for some specific package
> and it uses meson for build.   When I try to guix build the package,
> it fails with
> ERROR: Meson version is 0.53.2 but project requires >= 0.54
> I find meson later than 0.53.2 in guix already, but how in package
> definition to specify to use a particular meson version?  Thanks

I use something like this in my guix.scm for a package that uses meson
and requires a version newer than 0.53.2

  (guix build-system meson)
  (gnu packages build-tools)

(define-public foo
    (build-system meson-build-system)
     `(#:meson ,meson-0.55))

Note that the defintion of meson-0.55 in the build-tools.scm has the

;; Added temporarily for packages that need it.
;; TODO: Remove when core-updates is merged.
(define-public meson-0.55

So it might be safer to use meson-next to avoid breakage if/when
meson-0.55 gets removed.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]