[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Issue about building python on a foreign distro

From: Wade Zhang
Subject: Issue about building python on a foreign distro
Date: Sun, 22 Aug 2021 19:27:49 +0800

Hi all,

Recently I installed Guix on a Debian buster host.  I want to install all build
dependencies by Guix.  Since I use pyenv to manage Python versions, I have to
install Python outside Guix.  Now I get stuck during the Python installation.

I install dependencies by the following command:

guix install glibc gcc-toolchain make pkg-config libffi zlib bzip2
readline openssl sqlite xz xmlsec libxml2

# With ccache

At first I install ccache to speed up the building:

guix install ccache

When I run `pyenv install 3.8.11`, I got the following error:

checking for getaddrinfo... yes
checking getaddrinfo bug... yes
Fatal: You must get working getaddrinfo() function.
       or you can specify "--disable-ipv6".

I can build Python with packages installed by apt, so I think it's not an ipv6
problem.  I also tried to `apt-get install nscd` but the building still failed.

# Without ccache

Then I uninstall ccache and run `pyenv install 3.8.11`, I got another error:

*** WARNING: renaming "_ctypes" since importing it failed:
undefined symbol: ffi_prep_cif

Python build finished successfully!
The necessary bits to build these optional modules were not found:
_bz2                  _curses               _curses_panel
_dbm                  _gdbm                 _lzma
_sqlite3              _tkinter              readline
To find the necessary bits, look in in detect_modules() for
the module's name.

The following modules found by detect_modules() in, have been
built by the Makefile instead, as configured by the Setup files:
_abc                  atexit                pwd

Failed to build these modules:
_uuid                 nis

Following modules built successfully but were removed because they
could not be imported:

It seems all dependencies installed by Guix are not found.

I'm new to Guix, I have searched these message but can't find the solution.

Could you please tell me the reason of these errors and how to fix them?

Best Regards,

Wade Zhang

reply via email to

[Prev in Thread] Current Thread [Next in Thread]