[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issues with CUPS

From: Alexander Asteroth
Subject: Re: Issues with CUPS
Date: Sat, 04 Dec 2021 11:32:55 +0100
User-agent: mu4e 1.6.10; emacs 27.2

Hi Tobias,

thanks for the hint (see below). After touching /etc/cups/cupsd.conf it
immediately worked perfectly fine.

W.r.t. your other email:

> - Which PPD file did you import?  Was it[0]?  If not, try that.

I have no idea what it[0] is. The ppd I used before is from the Samsung
uld-package and is called Samsung_SCX-472x_Series.ppd

> - Why remove foomatic-filters from the default CUPS extensions   list?

I was not aware that adding filters to the service description overrides
the filters default values. I thought it just add's them and somewhere
it was remommended adding the hplib-minimal filters, and in my
helplessness I tried everything ;-)

Anyway, I gave other Samsung drivers a try and with the SCX-5330N I found a
driver that also seems to work with my SCX-4729.

... Now it works! Thanks!



On Fri, Dec 03 2021, 21:25:56, Tobias Geerinckx-Rice <> wrote:

> [[PGP Signed Part:Undecided]]
> Alexander,
> Alexander Asteroth 写道:
>> When the system is restarted and I try to access cups via
>> localhost:631,
>> after clicking on some (admin) link to add a printer (or similar) it
>> takes 2minutes (exactly) for the page to show up. In
>> /var/log/cups/access_log and .../error_log numerrous repeated
>> entries
> This sounds like the bug long fixed on core-updates (‘any day now’ :-)
> that hasn't made it to master yet[0].  A simple
>  $ sudo touch /etc/cups/cupsd.conf
> to create the file in question should work around it for now.
> Maybe remember to delete it post-c-u-merge, or don't; an empty file
> doesn't waste much space.
>> I have also another problem related to my printer wich is a Samsung
>> SCX-472x-series (accessed over ethernet). On the
>> suggested driver is
>> ( from
>> Samsung. So far I used it on debian and arch and it worked perfect,
>> but
>> I thik it's non-GPL.
> OpenPrinting claims that it's ‘MIT’ but a brief search didn't lead me
> to anything resembling source code.  Samsung's printer division being
> absorbed by HP doesn't help.
>> I can import only the ppd file for my printer but this refers to
>> some
>> filter
> Yeah, PPD files are just metadata files for actual printers/drivers
> and downloading them separately is usually pointless.
>> Any idea how to prodeed to get my printing working?
> Not really, I'm afraid.  The only Samsung laser printers I've ever
> used with Guix worked fine with SpliX.  It does not provide a 
> rastertospl filter, only rastertoqpdl.
> The most likely path forward is to find the sources to the
> pxlmono{-Samsung,} package if they exist.
> I started packaging the Ghostscript Printer Application this week,
> which we'll need when CUPS removes support for printer drivers 
> completely.  I'll check whether it contains anything relevant when I
> get back.  I'm not hopeful.
> Kind regards,
> T G-R
> [0]:
> [[End of PGP Signed Part]]

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]