[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot boot from microSD card on aarch64 machine

From: Maxim Cournoyer
Subject: Re: cannot boot from microSD card on aarch64 machine
Date: Wed, 30 Mar 2022 00:49:27 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.2 (gnu/linux)

Hi Ricardo,

Ricardo Wurmus <> writes:

> Hi,
>>> I mounted the target disk (an SSD) at /mnt, made sure that the microSD
>>> card was inserted, unmounted, and available at /dev/mmcblk1, and then
>>> ran
>>>    guix system init config.scm /mnt
>>> This was successful.
>>> Unfortunately, rebooting failed.  There is seemingly no activity at all
>>> when I power on the board, so something’s not right with how u-boot was
>>> installed on the microSD card.
>>> Does it perhaps install the u-boot files at the wrong offsets?  How
>>> would I begin to debug this?
>>> I’d appreciate any hints.
>> Sorry, I don't have any clue to offer, but were you able to solve or
>> workaround your problem?
> Not quite, but I’ve learned more and understand the problem better.
> I manually copied the two u-boot files to the expected offsets on the
> microsd card, and that let me boot Guix System from USB.  But I have so
> far been unsuccessful in my attempts to do this automatically as part of
> “guix system init” (I haven’t tried this much) or to successfully patch
> u-boot to boot from the SSD on the PCIe card (I have tried this a
> lot).

Heh, sounds tricky.

> My next step is to attempt to install the whole system onto the microsd
> card, just to end up with a usable system.  If that works then nothing
> is wrong with Guix (except for a lack of documentation), but it would be
> a disappointing workaround.
> I think it should be possible to patch u-boot to initialize the PCIe
> card and boot from the attached disk (with the patched u-boot residing
> on the microsd card).  I tried the relevant subset of the netbsd
> patches, but the CPU keeps resetting after (successfully) enumerating
> the PCI devices.

If I recall from my limited experience with an embedded ARM, you'd have
to register the newly supported hardware in the device tree of
U-Boot/the kernel; do the patches applied take care of that?

> I hope I can make some more time for this soon and overcome that last
> hurdle — and then write a cookbook entry for all this :)

I wish you luck!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]