[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix shell set user groups to access security token

From: Alexander Asteroth
Subject: Re: guix shell set user groups to access security token
Date: Sun, 15 Jan 2023 16:20:04 +0100
User-agent: mu4e 1.8.11; emacs 28.2

Thank's for the simple workaround. It helped to find out that the error
is not caused by the user's group ids. In fact it's related to missing
network access. I solved it by providing --network to the shell but
unfortunately this only worked exactly one single time. Now as soon as I
enable the network, the usb-connection to the token vis /dev/sg0 is not
estblished at all. Very strange (in particular, that it worked one

On Sun, Jan 15 2023, 14:11:45, Csepp <> wrote:

> Alexander Asteroth <> writes:
>> Dear all,
>> I'm trying to get my security token software (sealone) to work under
>> guix SD. The software is unfortunately not available in source and seems
>> to expect a FSH filesystem. I therefore tried to run it in guix shell. A
>> first trial was:
>> guix shell -CFD ungoogled-chromium gcc:lib --expose=/dev
>> in this environment I can execute the software and the tokes get's
>> connected but reports some error condition and is not usable. It might
>> have to do with the user not beeing in group cdrom which usually is
>> necessary to access /dev/sg0.
>> Any idea how to set the groups the user is member of in guix shell?
>> Or any other idea how I could get such software to work under guix?
>> Cheers,
>> Alex
> Bit of an ugly hack but what I usually do is chown devices I'm working
> with to myself.
> Haven't tried that in a guix container but in theory it should work.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]