[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

X window manager does not load

From: Nathan Gray
Subject: X window manager does not load
Date: Tue, 3 Feb 2009 09:18:22 -0500
User-agent: Mutt/1.5.18 (2008-05-17)

I recently installed the Hurd using the Debian CD (K-16).  Mostly it
was a good experience, using two guides:

There are several hangups that I have, and if I could have some
pointers, that would be much appreciated.

The first that I am seeking help with is my X installation.

I used the /cdrom/upgrade/ script from the Debian CD to install
X.  I used apt-get to install blackbox.

I changed from the Mach console to the Hurd console with the command:

  console -d vga -d pc_mouse --repeat=mouse -d pc_kbd --repeat=kbd -d 
generic_speaker -c /dev/vcs

When I ran startx, the graphical mode started, and I saw the X pointer
and weave background.  I also saw the popup error message:

  Warning: xrdb command not found; X resources not merged

When I clicked on 'okay', X shut down.

I then set up a new source in /etc/apt/sources.list:

  deb unstable main

I then ran 'apt-get update' and 'apt-get dist-upgrade'.  There were
some problems with apt while it tried to upgrade itself, but I got
things working again.

Now when I run startx, the graphical mode starts, I see the X pointer
and weave background, but the window manager does not load.

I tried adding first an ~/.xinitrc and then replacing it with an
~/.xsession file, but still I get no window manager.

  # ~/.xinitrc
  exec x-window-manager

My /usr/bin/x-window-manager is a symlink to
/etc/alternatives/x-window-manager, which is a symlink to

I have since installed fluxbox, but it also does not load.  And
finally wmaker, but it also does not load.

I am thinking that the problem is not which window manager I am trying
to load, but that something with my setup is not allowing any window
manager to load.

If I could have some pointers for commands I can run to get some idea
of what might be going wrong, or what I might try to fix the problem,
that would be most appreciated.


Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]