[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: X window manager does not load

From: Nathan Gray
Subject: Re: X window manager does not load
Date: Tue, 10 Feb 2009 14:05:01 -0500
User-agent: Mutt/1.5.18 (2008-05-17)

On Fri, Feb 06, 2009 at 09:22:45PM +0000, Bob Wilkinson wrote:
> On Wed, Feb 04, 2009 at 12:50:45PM -0500, Nathan Gray wrote:
>      So I would correct hostname - what does the command hostname say?
> If it looks wrong, then set it to something correct.

$ hostname

> Then read man xauth to see what sort of display name it needs. Run 
> echo $DISPLAY 
> to see what yours is set to.

I'm thinking that $DISPLAY is set by xinit.  I tried echoing $DISPLAY
in the startx script, but it is not set.

> I would also run
> grep -R h2:0 /etc/X11 
> to see where the command incorrectly using xauth is. 

The xauth calls are made in the startx script.  The problem is deeper
than that.  First I tried turning off xauth.  No difference.  Then I
tried calling xinit by itself (rather than from within startx).

Calling xinit by itself causes the graphical mode to load with the
weave background and X cursor, the same as when I call startx.  Then it
sits there for a while, then gives up with the error:

  xinit:  Operation not supported (errno 1073741869):  unable to connect to X 

I believe the problem is in xinit, or something deeper than that.

See this related thread:


Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]