[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Remote login demands password when none defined - dont want it to an

From: Bob Seabrook
Subject: Re: Remote login demands password when none defined - dont want it to anyway?
Date: Fri, 31 Aug 2001 15:27:51 +0100

Problem fully solved. Thanks Larry Jones

I had not replaced "-b /usr/bin" with "-f"
in the cvspserver line in inetd.conf.
I thought this was non critical
but it seems essential.

Thanks again Larry,

My instructions were taken from the 
CVS into in the book
Beginning Linux Programming. by
Richard Stones and Neil Matthew.
>From what we have here it seems its
a bit out of date.


-----Original Message-----
From:   Bob Seabrook [SMTP:address@hidden
Sent:   31 August 2001 12:25
To:     'address@hidden'
Subject:        Re: Remote login demands password when none defined - dont want 
it to anyway?

Thankyou Larry - this is helpful     (reply is quoted at end of this posting)

To answer your question,
I am using CVS version 1.10.7 (as supplied with Redhat 6.2 (zoot))
So, as you said I have to use a password.

Thanks to your kind help I have managed to get past
the login password prompt ok now, only to be confronted by yet
another error when I do a checkout over the network.
(remember I can checkout ok locally)
If anyone knows the reason for this error (below)
please let me know what it is.

once the cvs login is done I try to checkout my dummy test project
which is in a path called test/myshell which is 
under $CVSROOT/CVSROOT with the following command

  cvs co test/myshell

(co is shorthand for checkout)
This gives the error:

  cvs cannot open /root/.cvsignore Permission Denied
  cannot chdir(/root) Permission denied.

I am not logging in as root, so I dont know why
it insists on looking in root for this file.
So, I put an empty .cvsignore file in /root
on the server machine (to keep it quiet)
but it made no difference, tried cvsignore files
elsewhere like in ~ and CVSROOT did not help
either. Greppping the docs and man pages
for cvsingore just tells you what the file does
as one might expect, but a bit frustrating.

I am hoping this is the last barrier to getting familiar
with *USING* CVS - please help if you can.


On 30 August 2001 19:12, Larry Jones [SMTP:address@hidden wrote:
> Bob Seabrook writes:
> > 
> >   When I login to a new cvs installation (on a redhat 6.2 linux box)
> >   It demands a password but I dont want it to -
> >   and I dont know what it is either (anyway).
> It would be helpful to know exactly what version of CVS you have.
> >   the relevant line in /etc/inetd.conf is;-
> > 
> >      cvspserver stream tcp nowait root /usr/bin/cvs cvs -b /usr/bin 
> > --allow-root=/user/local/repository pserver
> Unless it's an ancient version, the "-b /usr/bin" has no effect and can
> be removed.  You should, however, have a "-f" in there.
> >   cvspserver is defined ok in /etc/services as;-
> > 
> >      cvspserver  2401/tcp
> >      cvspserver  2401/udp
> CVS doesn't use UDP, so that line can be safely deleted.
> >   I have edited /user/local/repository/CVSROOT/config
> >   so that password authentication is off! ie;-
> >      SystemAuth=no
> That doesn't disable password authentication, it says that you don't
> want to allow ordinary system users to login (to CVS) using their system
> passwords.
> >   when I create a passwd file containing the line
> >     Seabrook:
> >   or 
> >     Seabrook::
> >   ..and other lines.
> > 
> >   login also fails with the message
> > 
> >     cvs [login aborted]: authorization failed. Server 
> > rejected access
> Here's where the version of CVS becomes significant.  Allowing access
> with no password is a relatively recent feature (1.11, I believe) -- if
> your version of CVS is older than that, it won't work.  Also, there's no
> reason to login if you don't have a password (but it should still work).
> -Larry Jones
> Moms and reason are like oil 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]