[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Win32 cvs client - Unix cvs server

From: Sisyphus
Subject: Win32 cvs client - Unix cvs server
Date: Fri, 8 Apr 2005 12:36:39 +1000


The FAQ says that Win32 cvs clients don't get along with Unix cvs servers,
and the mix should be avoided. Is that advice still correct ?

I have cvs-1.11.19 (binaries obtained  from cvshome website) on my Windows
2000 box, and I have cvs-write permission to a sourceforge project. With
'pserver' I can 'login', 'co' and 'update' - but I can't 'commit' any
changes I make. All I ever get is:

cvs [server aborted]: "commit" requires write access to the repository

Well .... I do have write access - I assume the problem is that fact doesn't
get established.

Any ideas on what I can try ? - something that's going to have the process
prompt me for my password ? - or maybe some way of incorporating my password
into the 'commit' command ?

Following some advice I googled up I tried:

cvs -d:pserver:my_username:address@hidden commit -m
"message" file.ext

But still exactly the same response as quoted above.

I also found some advice on how to set the HOME environment variable in the
win32 shell - which I did. I can see '.cvspass' in the specified directory -
but still the same error.

If what I'm attempting is unlikely to work, then I'll go back to using my
linux box (where everything works fine). But that's a messy and fiddly
alternative, so I thought I should first check that I'm not overlooking
something simple re cvs on Win32.

The list archives also turned up some posts that indicated that 'commit' is
not going to work from the Win32 box, but the ones I saw were a couple of
years old. I'm hoping they're no longer correct.

All thoughts welcome :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]