[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS update -j <branch-tag> failes to merge

From: Jim Hyslop
Subject: Re: CVS update -j <branch-tag> failes to merge
Date: Fri, 13 May 2005 15:58:12 -0400
User-agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)

Asbjørn Sæbø wrote:
On Fri, May 13, 2005 at 10:04:59AM +0200, Asbjørn Sæbø wrote:

I have a CVS module (named "ldas") where I would like to merge the
contents of a branch into the trunk.  According to the documentation,
is seems that I should be able to du this using "cvs update -j
<branch-tag>".  However, this does not work.  No merging takes place,
the files on the trunk do not receive the changes from the branch.
address@hidden:~/ldas/utvikling$ cvs update -j dev_20050413_b ldas

However, when I changed into the ldas directory, and did the update,
it worked:

address@hidden:~/ldas/utvikling$ cd ldas
address@hidden:~/ldas/utvikling/ldas$ cvs update -j dev_20050413_b .
[Much retrieving and merging]

Is this difference between naming the module/directory and standing in
the module/directory expected behaviour?

No. I just tried it with cvs 1.11.20, and it worked OK:

C:\cvs-test\jim>cvs -d \cvs_repository tag -r brach_base -b abranch
cvs tag: Tagging .
T test.txt

C:\cvs-test\jim>cvs up -r abranch
cvs update: Updating .

C:\cvs-test\jim>echo branch changes>>test.txt

C:\cvs-test\jim>cvs ci -m "branch changes" test.txt
Checking in test.txt;
\cvs_repository/cvs-test/jim/test.txt,v  <--  test.txt
new revision:; previous revision: 1.2

C:\cvs-test>cvs up -A jim
cvs update: Updating jim
U jim/test.txt

C:\cvs-test>cvs up -j abranch jim
cvs update: Updating jim
RCS file: \cvs_repository/cvs-test/jim/test.txt,v
retrieving revision 1.2
retrieving revision
Merging differences between 1.2 and into test.txt

What version of client and server are you using?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]