[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: CVS Trigger for CruiseControl Configuration

From: Buorn, Yoway
Subject: RE: CVS Trigger for CruiseControl Configuration
Date: Wed, 25 May 2005 15:21:47 -0700

In case anyone is interested, I discovered that STDIN, STDOUT, and
STDERR are all capable of blocking a CVS commit.  My solution was to
redirect all three away to either a log or /dev/null.  This completely
dissociates the process from the parent shell and therefore allows the
loginfo script to run asynchronously, and therefore complete your commit
a lot more quickly.

-----Original Message-----
From: address@hidden
[mailto:address@hidden On Behalf Of
Buorn, Yoway
Sent: Tuesday, May 24, 2005 7:15 PM
To: address@hidden
Subject: RE: CVS Trigger for CruiseControl Configuration

I tried placing the entire rsh line in parentheses and following it with
the '&', but I'm getting the same result.  Although I don't have that
BUGS section in my man page, the -n option is listed, but it doesn't
seem to behave as expected.  When I specify -n, I always get output to
stdout.  I might shoot this question over to some scripting mailing
lists.  Thanks for all your help. 

-----Original Message-----
From: address@hidden [mailto:address@hidden
On Behalf Of Todd Denniston
Sent: Tuesday, May 24, 2005 2:56 PM
To: Buorn, Yoway
Subject: Re: CVS Trigger for CruiseControl Configuration

"Buorn, Yoway" wrote:
> Good call on removing eval.  I originally mistakenly assumed that eval

> was necessary to get ${REMCMD} expanded on the local machine 
> (${REMCMD} would be meaningless on the remote machine), but all I had 
> to do was remove the single quotes from ${REMCMD}.  Now my script is a

> bit cleaner, however, CVS commit is still waiting for Maven to 
> complete.  I now have the '&' after the rsh line (without eval).

just checked a local script we have ... I think may be the remote
command is eating the &.
you might try
rsh -l cruise -n \"${REMCMD}\" & or (rsh -l
cruise -n ${REMCMD} ) &

> There isn't any BUGS section in the rsh man page (Solaris 8).  Any 
> further suggestions would be appreciated.
the BUGS section I have:
     If you are using csh(1) and put a rsh in the background without
     ing its input away from the terminal, it will block even if no
reads are
     posted by the remote command.  If no input is desired you should
     the input of rsh to /dev/null using the -n option.

BTW: probably better to stay on the list, there are others out there who
may the answers better than I.

Todd Denniston
Crane Division, Naval Surface Warfare Center (NSWC Crane) Harnessing the
Power of Technology for the Warfighter

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]