[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Very odd cvs rm behavior, file not sent to the Attic

From: Pierre Asselin
Subject: Re: Very odd cvs rm behavior, file not sent to the Attic
Date: Sat, 20 Aug 2005 01:08:26 +0000 (UTC)
User-agent: tin/1.6.2-20030910 ("Pabbay") (UNIX) (NetBSD/2.0 (i386))

Sarah Gonzales <address@hidden> wrote:

> I'm experiencing some *very* odd behavior when a user attempted to  
> remove a file from a repository and would appreciate some help. User  
> removed a file correctly using cvs rm filename, but when he committed  
> the file, he received a permissions error.

>      cvs commit: cannot rename PathToFile/util.h,v to
>      PathToFile/Attic/util.h,v: Permission denied

> [ ... ]
> The permissions on the Attic are correct and this user is in the *NIX  
> group and the group has write perms.
> drwxrwxr-x        272 28 Apr  2004 Attic

Should be "drwxrsxr-x", unless your server is a BSD machine.  I
don't think it is the immediate source of your error, but it will
get in your way later.  The parent directory should have the same
group and permissions.

> The odd behavior is this...
> 1. the file doesn't appear in the Attic (as you would expect if the  
> permission to remove was denied)

> 2. the file util.h,v still exists in the src/ directory where it  
> lived originally

> 3. if we run a cvs co on the repository, util.h is NOT checked out  
> (desired since he attempted to remove it), but it does NOT live in  
> the Attic, it's still in its original directory.

I had similar problems recently because I mucked up a directory's
group or permissions.  Can you double-check?  The Attic/ directory
and its parent?

I fixed it by changing the permissions and moving the ,v file
to the Attic manually.  Worked fine ever since.

pa at panix dot com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]