[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Core dump

From: Mark D. Baushke
Subject: Re: Core dump
Date: Fri, 23 Sep 2005 09:02:28 -0700

Hash: SHA1

Thomson, Alisa <address@hidden> writes:

> I am using 1.11.19.  The command I tried is:
> jefferson{thomson}111: cvs -t -n import -m "Initial import"
> enegotiated/development fhlb v2
>  -> main loop with CVSROOT=:pserver:address@hidden:/apps/cvs
> Segmentation Fault (core dumped)
> Even though this is a development box, I do not have access to install
> gdb.

Hmmm... well, gdb does not need to be installed into any directory in
particular, you could even just add it to your own home directory and
use "$HOME/gdb /usr/local/bin/cvs core" (or whatever the path to the cvs
executable and the core file might happen to be).

> I tried your suggestion below which is adding the directories to the
> repository and it seemed to work for the files, but even after a commit
> the files do not show up in the repository...only the directory names.

Well, you would also need to do an

   cvs add filename

for each of the files you are adding and later do a 'cvs commit' to
commit them to the repository.

        -- Mark
> -----Original Message-----
> From: address@hidden
> [mailto:address@hidden On Behalf Of
> Mark D. Baushke
> Sent: Friday, September 23, 2005 3:44 AM
> To: Thomson, Alisa
> Cc: address@hidden
> Subject: Re: Core dump 
> Thomson, Alisa <address@hidden> writes:
> > I have cvs installed on Solaris and have been using it with relatively
> > few problems (just some directory renaming weirdisms) for about 8 
> > months.  It is still working fine on existing projects, but I am 
> > trying to create a new project and get a core dump on cvs import.  Any
> > ideas what could be affecting just the import?
> What version of cvs? Did you get a backtrace of the core dump? Was there
> any assertion error message printed as the output?
> Did you use 'cvs import -I ! module/path vendor vendortag' and also
> happen to have a 'CVS' directory in the import list? If so, you might
> want to use 'cvs import -I ! -I CVS module/path vendor vendortag'
> instead.
> Note that adding a new project need not be done via a 'cvs import'
> command, you may also use something like
>   cvs checkout -d top .
>   cd top
>   mkdir new-module-name
>   cvs add new-module-name
>   : and then add more files as you wish and commit them as normal

...disclaimers idiocy elided...

        -- Mark
Version: GnuPG v1.2.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]