[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS/Entries file not including directories

From: Jim Hyslop
Subject: Re: CVS/Entries file not including directories
Date: Fri, 30 Sep 2005 19:40:47 -0400
User-agent: Mozilla Thunderbird 1.0.6 (Windows/20050716)

[forwarding to list - please remember to "Reply All" in future]
Puckett, Mariellen wrote:
-----Original Message-----
From: address@hidden [mailto:address@hidden Sent: Friday, September 30, 2005 11:05 AM
To: Puckett, Mariellen
Cc: address@hidden
Subject: Re: CVS/Entries file not including directories

[ccing info-cvs list and attaching log]
Puckett, Mariellen wrote:

Running on Windows/XP Server
cygwin / bash environment
ant 1.6.2
cvs 1.11.17 client (fails in 1.12.9 as well)
cvs 1.12 server

The projects directory is pretty large, not sure if it's a buffer
overflow problem or not, but that's the only directory that IS NOT
getting populated into the Entries file.

I'm using ant commands to do the checkout (i.e. ant package="xng" and
then to tag it ant cvs command="tag build_tag xng"

Let me know if you need any more info.  I trimmed the log to just
contain the output from the tag command.

We're getting there, but you've got to give us more information - we can't work in a vacuum. Please make sure you answer all the questions - some of these questions have been asked before with no answer.

The more information we have, the easier it will be to help you resolve this issue (remember that a 140KB log file is not information, it's raw data).
Here's the answers to your questions:
How do you know the tag didn't succeed?
The only reason I found that it wasn't tagging the projects directory
was someone tried to checkout the build tag and wasn't getting the
projects folder.  I then looked at the Entries file and noticed it
wasn't in there. I then tried to manually tag it and cvs didn't tag it because it didn't
know about it via the Entries file.
What is the output of 'cvs version'? I put this info above. It fails with cvs versions 1.11.17
and 1.12.9

Which directories succeed, and which fail? The directories that are added to the Entries file are no different
other than "size" to the projects directory that doesn't get added.  The
projects directory is 1.66 gig
What happens if you issue the tag command from the command line, and not through ant?
I've tried doing a cvs checkout from command line instead of using ant
cvs command and I get the same results.  The projects directory doesn't
get added to the Entries file, and, therefore, it doesn't get tagged.
If you try to tag the projects directory when it's not in the Entries
file it won't work.  Get ???? for directories.

Is there any way to see exactly what command ant issues to cvs, and if so what is the exact command? This is the first time you've mentioned either cygwin or ant - is there any other relevant information we should know?

I believe I gave you all the info about my environment.  I know it's
hard to try and debug something like this but it's a serious problem and
I'm not sure what else to do about it.  Adding the update command right
after the checkout fixes the problem by then adding the projects
directory to the Entries file but now that doubles the time to do a
checkout and update against a 1.66 gig directory.

So, I run cygwin on windows running a bash shell and I use ant to call
cvs, but I tried just using the cvs command and it has the same

Thanks for your time.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]