[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Fw: password mismatch

From: Claude . Daoust
Subject: Fw: password mismatch
Date: Thu, 9 Feb 2006 13:50:59 -0500

Sorry perhaps I didn't make it very clear but the user I logged in as was
cvsbuild when I ran the telnet session and worked with the repository.  So
the user does in fact exist and CVS itself runs as this user.  Our admin
tells me the password is in the password file - but perhaps he is mistaken?
Is this a manual step?

At one point I thought the issue might be that it is the same user as the
one CVS is executing under so we created a second ID, cvsuser, which
unfortunately produced the exact same results.

> Message: 2
> Date: Mon, 06 Feb 2006 20:01:40 GMT
> From: Mike <address@hidden>
> Subject: Re: CVS on AIX PSERVER password mismatch issue
> To: address@hidden
> Message-ID: <address@hidden>
> On 2006-02-06, address@hidden <address@hidden> wrote:
> > We have recently been asked to migrate our CVSNT repository to AIX
> > The base install of CVS was carried out by UNIX admins and then passed
> > to us to populate.  Unfortunately, PSERVER access still does not work.
> > There were several issues that were worked out with the PSERVER access.
> > One of the admins turned out some logging that showed CVS trying to
> > authenticate the user and the resultant error which was "password
> > mismatch".  The password is indeed correct so I am guessing that CVS
> > not have the authority to get the correct system password??  If I
> > into the AIX box (user cvsbuild) I can work with the files in the
> > repository (checkout and so on) so we are almost there.
> >
> > Here's our setup.  We have 1 system user - cvsbuild - which everyone
> > aliased to in the .passwd file in CVSROOT.
> >       i.e.  claude:kZomPwdlTc:cvsbuild
> > When I try a remote CVS login using pserver with cvsbuild CVS returns:
> >       cvs [login aborted]: authorization failed: server harvbldp
> > access to /cvsrepo/dev for user cvsbuild
> > I also get the following in the auth.log:
> >       syslog: password mismatch for cvsbuild: **G.26Qx3VFAw vs. *
> > If I try one of the aliased users CVS responds with:
> >       Fatal error, aborting.
> >       : no such system usercvsbuild
> >
> > It seems like CVS cannot do what it needs to do to authorize
> > the system user.  We are not using the PAM stuff.  Any advice, hints,
> > would be appreciated!
> How's this?
> - create a 'cvsbuild' account on the aix box
> - put the encrypted password in /etc/security/password in your
> CVSROOT/password file
> - remove whatever passes for .cvspass on the windows box
> - authenticate again to cvs 'cvs login'

This e-mail and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed.  If 
you are not the intended recipient, you are hereby notified that any 
disclosure, copying, distribution, or taking any action in reliance on the 
information contained in this e-mail is prohibited.  If you have received this 
e-mail in error, please immediately notify your e-mail administrator.

Blue Cross & Blue Shield of Rhode Island
in-state: (401) 751-1673
out of state: 1-800-343-5743

reply via email to

[Prev in Thread] Current Thread [Next in Thread]