[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: init error in Suse 10.1: cannot get working directory: File exists

From: Todd Denniston
Subject: Re: init error in Suse 10.1: cannot get working directory: File exists
Date: Thu, 26 Jul 2007 07:45:15 -0500
User-agent: Thunderbird (X11/20070716)

Frank Jelinek wrote, On 07/25/2007 03:17 PM:
Hi Todd,

thank you for answering. Actually I made some additional tests. At first I tried your hints, but no changes. My root-home ist root-Writeable, so there is no problem.

I patched the source code to tackle the problem. Result: the xgetcwd func seems to fail. I replaced it by the native getcwd and everything works.

This could be an issue for the development mailing list, therefore I cc'ed to this list. Perhaps one of the developer could take a look at the problem, I guess that there is a platform incompatibility with the gnulib

There is no address@hidden, it is bug-cvs.
I believe it would be appropriate for a bug to be entered for this.

Would you please:
A) collect appropriate information (processor, 32/64 bit mode, distro & release + update status, version of CVS you compiled).
B) run the `make check`
for both an unmodified CVS code set and for the one you modified, as the devs will want to know if the tests pick up the breakage. C) take a look at the HACKING guide to see if there are other things the devs will want that you can provide.
especially the "Writing patches (strategy)" & "Writing patches (tactics)" sections. D) take the information from A, C, and appropriate parts of B and drop them in a bug
BTW the bug entry will drop a message to address@hidden


Denniston, Todd A CIV NAVSURFWARCENDIV Crane, Code 6067 wrote:
address@hidden wrote:

I'm looking for help. Actually it is not my first cvs system I set up, but the problem is new to me.

I have a Suse 10.1 root server. There I install cvs, I tried the standard yast installation (seems to install a suse-patched cvs 1.12.12) and I tried a self-compiled 1.12.13. Both results in the same problem.

I'm logged in as root (with other users it is the same) and I try to create a new repository with the command

cvs -d /root/cvs init

The result is

cvs [init aborted]: cannot get working directory: File exists

The same result I get if I try any other command and with different user accounts. I also tried the

cvs -t -f -d /root/cvs init

options. Then I get

  -> main: Session ID is L7NaPCpnLvgrC7rs
cvs [init aborted]: cannot get working directory: File exists

with google etc I did not found any hint, so I hope that someone here could help me. Is there anyone who have a similiar problem? And a solution ? Or ca I tackle the problem trough changes in the source code?


Todd Denniston
Crane Division, Naval Surface Warfare Center (NSWC Crane)
Harnessing the Power of Technology for the Warfighter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]