[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Disappearing Root files

From: Todd Denniston
Subject: Re: Disappearing Root files
Date: Mon, 26 Nov 2007 13:51:56 -0500
User-agent: Thunderbird (X11/20071031)

Mark E. Hamilton wrote, On 11/26/2007 12:02 PM:
I've got a strange problem occurring. On one of our machines in the directory where we do our nightly checkout/build/test process, some (but not all) of the CVS/Root files are disappearing. I have no reason at this time to think that CVS is doing this (unless someone here has seen this themselves.) I'm going to have to search through our code to see if we're doing this somehow, somewhere.

You would not happen to be doing your "nightly checkout/build/test process" under /tmp/ would you?

I have seen similar problems with folks who tried to work under tmp for a while. The tmp cleaner would come along and see the file had not been changed for ~1 week and remove it, slowly deleting everything. :)

CVS/Root is one of those files that usually does not change after checkout.

If you are not working in /tmp, you might ask (with a big stick in hand as needed) the machine admin if (s)he has a helper running against that directory structure to get rid of files that have not been "used||changed" for a while.

However, when I discovered this I thought checkout or update would put the Root files back again. I tried both

cvs -d repos checkout dir
cd dir && cvs -d repos update -dP

Both worked, but neither restored the missing Root files. Should they have, or is this something that has never come up before?

IIRC CVS only requires the CVS/Root file in the directory where it first starts working.

Todd Denniston
Crane Division, Naval Surface Warfare Center (NSWC Crane)
Harnessing the Power of Technology for the Warfighter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]