libtool-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SCO/bugfix patch 7 of 10: Improve SCO platform support


From: Kean Johnston
Subject: Re: SCO/bugfix patch 7 of 10: Improve SCO platform support
Date: Thu, 10 Nov 2005 13:35:09 -0800
User-agent: Mozilla Thunderbird 1.0.7 (Windows/20050923)

The way I understand your intentions, it should suffice if you can
decide at configure time about the absoluteness of the paths (rather
than at link time).  So you could do this instead:

  if test -z "$SCOABSPATH"; then
    archive_cmds='bla bla'
    archive_expsyms_cmds='bla otherbla'
  else
    # ...
  fi

which would be at least a lot more readable.
Sure, I can do that, I'm open for compromise :) The only reason
I did it the way it currently stands is it allows me to do the
following:

  ./configure
  make install
  make clean
  SCOABSPATH=1 make install DESTDIR=/whatever

with no intervening re-running of configure in between. In fact
the SCOABSPATH thing as it currently stands used to look a great
deal neater. Perhaps this would be more acceptable (I suspect it
might), so that I can preserve the above behaviour (line split
by mailer, not in script):

  archive_cmds='$CC -shared
    ${wl},-h${SCOABSPATH:+${install_libdir}/}$soname -o $lib
    $libobjs $deplibs $compiler_flags'

It has the exact same effect, but looks a *great* deal cleaner.
In fact, before I submitted the patch thats how it looked. I
changed it to the current mechanism becuase I thought it made
it more obvious what was happening. But I can see your point
about it being ugly as sin.

If even that is too ugly for you, then I guess I can live with
the pain of having to re-run configure to enable the absolute
path stuff, but I'm really hoping not :)

about moving the hack forward if that doesn't work out).  At the first
occurrence of SCOABSPATH, please add a comment that this thingy will not
be supported, and that it breaks testing of uninstalled libraries.
I can certainly do that. Is there a suitable place in the doc
for platform specific quirks that I can document it more
eloquently and obviously too?

Kean




reply via email to

[Prev in Thread] Current Thread [Next in Thread]